Support Website Contact Support Blog

Tree not appearing in mesh

 

I keep getting missing trees and holes in my mesh even in areas where there are sufficient points in the dense cloud (such as the purple maple tree in the images below). How do I force these points to be considered when generating the mesh? Even a floating tree is better than no tree at all.

Also under the eves of the roof are holes in the mesh. I have processed similar projects which have been able to fill in these areas when generating the mesh. Ideas? I already tried upping the number of polygons from 1 million to 5 million.

 

Initial Processing Details

info

System Information

info
Hardware CPU: Intel® Core™ i7-7700K CPU @ 4.20GHz
RAM: 32GB
GPU: NVIDIA GeForce GTX 1070 (Driver: 23.21.13.9135)
Operating System Windows 10 Pro, 64-bit

Summary

info
Project dads_house_3_all
Processed 2018-09-06 23:22:34
Camera Model Name(s) FC6310_8.8_5472x3648 (RGB)
Average Ground Sampling Distance (GSD) 1.33 cm / 0.52 in
Time for Initial Processing (without report) 01h:35m:24s

Quality Check

info
help Images median of 52564 keypoints per image green
help Dataset 811 out of 811 images calibrated (100%), all images enabled green
help Camera Optimization 0.17% relative difference between initial and optimized internal camera parameters red
help Matching median of 12980.5 matches per calibrated image green
help Georeferencing yes, no 3D GCP yellow

Calibration Details

info
Number of Calibrated Images 811 out of 811
Number of Geolocated Images 811 out of 811

Coordinate Systems

info
Image Coordinate System WGS84 (egm96)
Output Coordinate System NAD_1983_StatePlane_Idaho_West_FIPS_1103_Feet (egm96)

Processing Options

info
Detected Template dads_house_3_all*
Keypoints Image Scale Full, Image Scale: 1
Advanced: Matching Image Pairs Free Flight or Terrestrial
Advanced: Matching Strategy Use Geometrically Verified Matching: no
Advanced: Keypoint Extraction Targeted Number of Keypoints: Automatic
Advanced: Calibration Calibration Method: Standard
Internal Parameters Optimization: All
External Parameters Optimization: All
Rematch: Auto, no

Point Cloud Densification details

info

Processing Options

info
Image Scale multiscale, 1/2 (Half image size, Default)
Point Density Optimal
Minimum Number of Matches 3
3D Textured Mesh Generation yes
3D Textured Mesh Settings: Resolution: High Resolution
Color Balancing: no
LOD Generated: no
Advanced: 3D Textured Mesh Settings Sample Density Divider: 1
Advanced: Image Groups group1
Advanced: Use Processing Area yes
Advanced: Use Annotations yes
Time for Point Cloud Densification 08h:31m:05s
Time for Point Cloud Classification NA
Time for 3D Textured Mesh Generation 39m:10s

Results

info
Number of Processed Clusters 2
Number of Generated Tiles 1
Number of 3D Densified Points 24077047
Average Density (per ft3) 117.77

DSM, Orthomosaic and Index Details

info

Processing Options

info
DSM and Orthomosaic Resolution 1 x GSD (1.33 [cm/pixel])
DSM Filters Noise Filtering: yes
Surface Smoothing: yes, Type: Sharp
Orthomosaic Generated: yes
Merge Tiles: yes
GeoTIFF Without Transparency: no
Google Maps Tiles and KML: no
Time for DSM Generation 00s
Time for Orthomosaic Generation 01h:17m:44s
Time for DTM Generation 00s
Time for Contour Lines Generation 00s
Time for Reflectance Map Generation 00s
Time for Index Map Generation 00s

Hi,

Usually, when some objects are removed from the mesh is due to the fact that the underlying pointcloud is not dense enough.

I would suggest generating a denser point cloud in Step2.

Regards.