Holes in mesh


I’m currently processing project with 3.2k images captured by EbeeX drone (overlaps are 75%). I have a problem with generating 3D mesh based on dense point cloud. Point cloud was generated correctly with points overlooking all of area but mesh create a hole in the data. I tried processing it twice - same result. What is the cause of this problem?

Hi @Jerzy_Trebicki ,

Thank you for posting your question in the Pix4D Community.

Which processing template did you use to process your project?
What are the settings you used for Point Cloud Densification?

Template - 3D Maps under Standard.

Below pointcloud processing options.


Please try to change the Image Scale to 1/1.
The image scale defines the scale of the images at which additional 3D points are computed.

  • 1/1 (Original image size, Slow) : The original image size is used to compute additional 3D points. This option require four times more RAM and processing time than when processing with the default value 1/2.

You could also try to switch Point Density to High (slow). Take into account that the processing speed will be affected significantly.

If modifying the point cloud does not help, you can also try to modify the 3D Textured Mesh settings as described in this article:

Let me know how it goes.