Some holes(empty part) in the point cloud

Hi there,
I’m Chloe and I have some problem with mapping at the moment.
I mapped the rooftop of a building and there are some holes which is not mapped at all so there is some empty part in the point cloud.
Does anybody know why it is and what I can do to fill there?
Additionally, I’m mapping in the Pix4D and editing in cloudcompare.

Hi chloe,
It appears that the rooftop is a very homogenous surface. There is simply too little texture or content for the software to work with. I would suggest changing your point cloud density to high. This might help fill the holes.

I don’t think the point density setting is going to help much on that one. Lowering the minimum number of matches from 3 to 2 might help in those areas (but you’re going to get -a lot- more noise and the points generated in those areas would likely be very noisy as well). The multiscale option normally helps there, but you already have that checked.

Changing the image size from 1/2 to full MIGHT help if used in conjunction with multiscale. Full image size for point generation might find additional identifying features to generate points in those areas, and the multiscale option will allow it to try using the lower resolution image sizes to fill them in as well (which would include the 1/2 setting in Mike’s screenshot). You could also try changing the matching window to 9x9 in the “Advanced” tab.

As far as I can tell in a 2D view, what you have here really doesn’t look bad to me. The biggest tips I’d give for further improving it would be

  • low-alt flights with stop and shoot photo captures (don’t shoot on the move)
    -Consider using auto-exposure -IF- you’re doing stop and shoot (Always use shutter-priority when shooting on the move)
    -Crank your overlap and sidelap up. If most of your work is building rooves, the difference between 70%/70% and 90%/90% really isn’t that much extra time. (I mainly do topographic surveys 5acres to 4,000 acres, so the overlap difference has a huge impact).

You could also try pre-processing photos with a batch process in Lightroom, but it’s possible to make the problem worse and I’d prefer to just dial in the exposure settings in the field.

I tried what you told and it’s much better.
Thank you very much

1 Like