Support Website Contact Support Blog

Thermal Orthomosiac Issues

I am trying to stitch thermal orthos and cannot get any usable results. Most of the cameras wont calibrate, no more than 50% on most projects. For many projects there are automatic tie points that extend far past the ground and seem to be located in dozens of images.


The cameras are also very far from the original location,
If I do get the images to calibrate the ortho turns out all splotchy and deformed.

Any help with this would be appreciated as I have several thermal projects>

When I am using the Alternative calibration method I get very few cameras calibrated but when I use Accurate Geolocation and Orientation I get almost 100% of the images calibrated.

Oilivia, It means either the camera parameters are wrong or there are oblique images in the dataset. Can you share a scrreenshot of the image properties editor showing the camera parameters (focal length, pixel value etc)?

Hi Olivia,

Are you processing two different flights together?
If so, it is recommended to process them separately and then merge them.

Could you please also provide us the quality report from the “Accurate Geolocation and Orientation” processing?
We would like to have a look on it.

Thank you,
Best

So there are two flights but I am processing them separately.
wmdc6097 single flight_report.pdf (1.2 MB)

Hi Olivia,

This projects shows that two different acquisitions have been processed to together:
image

If you process images that have different GSD it will have some difficulties to find matches.
Your camera parameters are good.
I would just make sure that there is enough overlap (what’s you overlap?) in each of your acquisition and I would also use “All Prior” for the Internal Parameters Optimization.
So my recommendation: Make sure that each for your acquisition have at least 90% overlap.
Process each acquisition separately with your processing option (+ All Prior).
If they do not calibrated, send us the quality reports.
If it works, then merge them.

Hope this will help.
Best

So I tried that and it still didnt work. I’ve been processing several different thermal projects and they all turn out the same way. I have tried at least 5 different locations flown by different pilots but they all keep doing the same thing. Each of the locations have 85% overlap in each direction. Here is the most recent quality report. wmdc6097 section 2_report.pdf (745.4 KB)

Hi @olivia
Thank you. It is recommended to have 90% overlap in each direction.
Could try using the calibration method “Accurate Geolocation and Orientation” for the project wmdc6097 section 2 (and rematch: yes)?
(You used Alternative)

I would also try with the image scale on 1, it could help to find matches.

If it does not help , could you please upload your data set in the Cloud (or share it through a drive) and provide us the project number so we can test it on your side if we manage to calibrate your project.
Best,

Hi @Marco
I have tried that previously and that is what gave me the results in the first image in the thread. I can get 100% of the images to calibrate but i get the splotchy ortho that is of no use to us. You can find all of the images for this project at https://drive.google.com/open?id=1vboVeUH3xeuuL-R2MHSaNVU6T8f3MRvn

Hi @olivia

We had a look at your dataset and tried to process with several options. The images do not seem to have enough overlap, some do and most do not. the overlap does not look uniform, maybe the flight speed was high or there was wind, or the camera did not trigger correctly. You can see this from the flight plan below:

image

Also, the intensity of the images differ a lot.These are two consecutive images for example and the pixels should have the same temperature but you can see how much it differs. You can have a look at this: https://support.pix4d.com/hc/en-us/articles/360000173463-Processing-thermal-images#label6

Let us know if you have any questions.