Support Website Contact Support Blog

Takeoff checklist issue in Pix4Dcapture

After completing the flight plan, I click on start. In the ckecklist, accuse mission is far away. Reboot the drone, control, cell phone. I tried to change the takeoff location, change the battery, and change the telephone set in which the application is installed. I calibrated the drone again. But it’s no good, continues mission is far away. The scheduled flight is 15 minutes, at a height of 90 meters. How can I solve? 

My drone is a Phantom 3 standard.

Thanks.

Hi Luiza,

Are you using the Android or iOS version of Pix4Dcapture?
In a first time as your issue seems related to the safety implemented about the flight distance, I would recommend having a look at this article on our Knowledge Base.
It explains how you can bypass the safety locks, itz should enable you to pass the takeoff checklist and fly your mission.

Best,

1 Like

 

Good afternoon.

I use the Android version.

I read the article and clarified. The problem was solved. However, the checklist is getting all green, and when I ask to take off, the drone does not turn on. And this error appears on the screen. How can I solve?

Hi Luiza,

In a general way, when having an issue, we suggest following the basic checks and troubleshooting steps. If properly followed, it will enable to solve most of the issues encountered by users.

Usually, when bumping into “Mission cannot be started because of DJI internal error”, some parameter set in the drone manufacturer application is conflicting with the Pix4Dcapture mission you are planning (maximum flight height…).

As an additional question:

  • Have you been able to fly using the same configuration before?
  • Are you updated with the latest drone firmware and Pix4Dcapture version?

Best,

Good night, I have already completed six flights with the current configuration, using the same height and flight size.

I have already completed six flights with the current configuration, using the same height and flight size. I checked today and there are no firmware updates or version of Pix4Dcapture.

This error has happened previously, sporadically. Other times, I wait one day and try to fly again, and it works perfectly.

The problem is that I will start a job in another city, and I need to know what to do when I give this problem, because I can not wait for another day.

Thank you very much in advance.

Hi Luiza,

Thank you for the additional details, From the past experience, this issue can show up sporadically and seems to be related to the DJI SDK (Software Development Kit). The root cause of it has not been identified.

However, going through the following steps should enable you to fly properly:

  • Being sure that no Settings in DJI GO can conflict with the mission set in Pix4Dcapture
  • That the SD card is working fine. You can try another SD card if possible.
  • Restart everything from scratch if the issue occurs. To do so, close and force quit the app, disconnect the cable from the mobile device, turn off the remote controller and the drone. Then switch on the drone and the controller, reconnect the USB cable and open Pix4Dcapture. On Android, launch Pix4Dcapture from Ctrl+plugin.
  • Reinstall DJI GO.

It can also be considered to reinstall Pix4Dcapture from scratch following the procedure below:

Caution

The two procedures below may imply data loss so we recommend to make a backup if there are important data saved. Connect the mobile device and copy the Pix4D folder (Local Storage > Device storage > Pix4D) to your computer.

1. Clear data and clear cache memory of the application

  1. Open the Settings application on the Android device.
  2. Scroll the list and tap Apps, Applications or Manage apps.
  3. (optional) On certain devices like Samsung, tap Application Manager.
  4. Scroll the list to find the application.
  5. From the list, tap Storage.
  6. Tap CLEAR DATA and CLEAR CACHE.

2. Re-install Ctrl+Plugin and Pix4Dcapture from scratch

  1. Uninstall Pix4Dcapture and Ctrl+Plugin.
  2. Connect the device to a computer and navigate to Local Storage > Device storage > Pix4D.
  3. Delete the content of all folders.
  4. Delete the Pix4D folder.
  5. Re-install the latest version of Pix4Dcapture and Ctrl+Plugin.
  6. (optional) Place the backup content back into the Pix4D folder to restore data.

Best,

1 Like

Good night,

I reinstalled the application and the problem did not occur again. Thank you!