Support Website Contact Support Blog

Stitching XT2 themal images

Hi,

I have a new Zenmuse XT2 camera and would like to create a thermal mosaic. Although I have not flown a grid yet (as I have an M210 and DJI Pilot can’t do that yet) I thought I would try with some images I collected using a 5 sec interval. To test PIX4D I tried loading a few of these images  but I immediately received the following error after uploading the images. Any thoughts on why this failed so quickly?

[Error]: Error converting FLIR image: This is not an IR image: C:/Users/Desktop/100MEDIA/DJI_0011_R.JPG

[UI]: FLIR extraction cancelled by user

Hello Peter,

You can find a lot of information no how to process thermal images here.

As for the message that you are getting, I would say that you are trying to load RGB images and not thermal IR.

What files do you have?

Thank you very much.

Hi Peter,

We currently have difficulties in extracting the r-jpeg imagery from FLIR cameras. We have contracted FLIR from our side to see what causes this issue. We believe that the latest changes of FLIR SDK do not align with our algorithms.

As soon I will have news from my side I will write you back.

We have taken images from the same camera multiple times. Sometimes it extracts and works and some times we get the same error: 

Error converting FLIR image: This is not an IR image

 

XT2 - 19mm on 210RTK. 

A workaround is to use the flir tool (ThermalFolder.exe) and change any setting (I use emmisivity). After that the modified versions can be extracted by Pix4D.

As an FYI, that tool somehow breaks the GEO tag even though in EXIF it is still there.

@John Thank you for the workaround :slight_smile:

@all This has been fixed and will be working perfectly in the next version.

Is this “perfectly working” version available in a Beta?

Yes, can you please be explicit about the version we will see this in? ie. will it be Pix4D Desktop 4.3.28 ?

Yes, it will be 4.3.28.

Hi all,

Version 4.3.31 is out and the issue has been fixed. You can have a look here: https://support.pix4d.com/hc/en-us/articles/115005738363-Pix4D-Desktop-technical-release-notes

Hi there, 

Having a similar issue:

[Error]: Error converting FLIR image: Unable to write thermal image

Xt2 / M600P

I have the newest version. 

@Eloise can you write a support ticket and send us the images (maybe 10-15). I would like to test it from my side.

Hi @Momtanu.

 

Has this been resolved. Using the FLIR XT2 & Pix4DBIM?

Hi David, this has been fixed. Are you having any issues?

Hi Momtanu Im having issues with an XT2 camera only giving me grayscale options for the bands. Is there any way to fix this?

Hi Ryan,

I have answered to your support ticket. We can follow up later on this page. Thanks :slight_smile:

Hi Momtanu,

Did you fix the issue? I am importing images collected from the XT2 and Pix4D is converting them to greyscale. When i want to open them in the map view, there is no visible content.

If i try to run Step 1 the error “Exception found trying to select keypoints: Input keypoints are empty” shows up. 

 

Greetings,

Marc

Hi Marc,

This error seems to indicate that the software could not detect key points while processing and thus couldn’t find the results that were generated for step 1. Initial Processing.

Do the raw images look good?
Have you checked the camera settings before capturing?

The images are looking okay for me. But it was the first time i have done that so i have no comparison.

It seems as if Pix4D is not able import these images properly as i am not seeing any content when opening them in the Map View. They are automatically converted to greyscale, but this only works for some images. Most of them are like 45kb with no content at all.

Before converting to greyscale they look like: