Support Website Contact Support Blog

Ray Cloud Textured Mesh is Black

Hello,

 

I’m having an issue where, when viewing the 3D Textured Mesh in the Ray Cloud, the mesh is showing up in all black, not the textured photo that it used to.  The colors load fine if I switch it to Topo or Monochrome, and the texture file is generating properly as the full texture loads when I open the .obj file in other programs, however for whatever reason, the textured mesh is all black when I load it.  

 

Has anyone else had this problem or have any advice on how to fix it?  I’ve tried fully uninstalling and reinstalling Pix on my computer and that doesn’t seem to work.  

 

Thanks,

 

Logan

+1 here

Hey Victor,

I found out the issue on my end (hopefully it helps you too).

It looks like the workstation that I was using actually had two GPUs installed in it, one was integrated into the CPU, and the other dedicated (Nvidia GTX 960).  Strangely enough, the thing that fixed it was simply unplugging the video output from one HDMI port in the back, that was apparently connected to the integrated GPU, and plugging it into the dedicated GPU.  This fixed it for me, hopefully its a similar issue for you.  

Hi Logan

That explains a lot… I’m working on a DELL laptop with an integrated GPU only. 

A big issue for a 2K+ eur software… fortunately, I’m with a trial ATM, and I can open the mesh with MeshLab without problems.

Thanks for your help. 

I am currently experiencing the same problem.  In the past I did not have this issue.  I have been using P4D for over a year now, but since the release of 2.0, all my meshes are black.  When I open the OBJ file and texture in other programs it works fine, but inside P4D it remains black.  With the release of 2.2 and the ability to further edit the mesh, this is major issue for me.  I am running and Dell 7710 workstation with Nvidia Quadro M3000M 

 

P4D support, can you help with this?

hello, i have the same problem, on my laptop with NVIDIA 1060 and on my desktop dell T7610, a solution please

Hello everyone, 

What might happens is that the screen is not focused on the project and the point cloud is located somewhere else: 

Try to select an automatic tie point on the left sidebar and press the key “F”
(or select rayCloud -> Viewpoint -> Focus on Selection).

This will focus on the point cloud and might find the lost point cloud.

Otherwise, it might also be that the GPU does not support OpenGL 3.2, in which case you cannot see the rayCloud.

You can see the system requirements here:
https://support.pix4d.com/hc/en-us/articles/202557289. 

 

Best Regards, 

+1

Definitely seems like GPU is now a requirement even though it wasn’t in the past.