Support Website Contact Support Blog

RayCloud all black (no layer displayed) problem and mtps

Hi, first of all i need to excuse for my bad english skill…

But, i was looking for the solution for the ray cloud problem, because my project i was working on for days, in a while became all black with no layer displayed… On the troubleshooting it advice to update the driver of your Graphic card, due to opengl 3.2 support… But only in few of my tries the problem appears. If it would be the opengl, all my project would not work at all.

I am running the pix4d 2.2 preview, and after having opened a “black raycloud” file, i made a mistake and i click on the “volume” menu, and the model (mesh and point cloud) magically appear on my screen. If i try to go to the raycloud, it’s not displayed at all.

So i was wondering which was the differences in visualization volumes menu and raycloud menu. And the solution is: MTPs.

So i tried to delete all my MTPs taken from polylines and surfaces, save and close the project, and finally the raycloud became alive!.

The problem is not the opengl, the problem should be the way the mtps are displayed in the raycloud, they don’t allow the raycloud to inizialize.

Now: pix4d support, could you suggest me a way to fix the problem? is there a method to import the mtps and other object in a “blank scene”, i mean a processed scene. Or maybe you know the problem and you know how to fix it…

My configuration is: Pix4d 2.2 preview

Asus x99e ws, intel i7 5820k, 32gb ram ddr4, dual gigabyte980Ti and one msi 960 4gb, all up to date… so the hardware could not be the problem…

I finally got the point!!! maybe it’s only a bug of the 2.2.15 version, because  with the old (and tested) version i’ve never had this problem.

The raycloud is total black if i have more than 1 MTPs with no point set on the image.

I try to explain with 2 screenshot:

I had few MTPs with no point marked on the image… the raycloud all black.

I’ve deleted only those points and…

Open and close the file and the raycloud is working properly.

 

Pix4d support team, give a look at this problem.

Hi Nikolay,

Thank you for your post and sharing the solution you have found.

The black screen of the rayCloud could happen because the software is focusing on a a wrong area instead of focusing on the real location of the model. To solve the problem, could you try to select an element (a camera for example) and click the Focus on Selection button? If this does not focus on the model then it might be something else.

Let us know if this works.

Regards,

It worked! focusing on a camera on the model it “appears” in the right position… those polylines out of the view are the points without any mark on the image. Problem solved. Thank you

I have another question about this “problem”…

Why the mtps that i haven’t marked on other image after restarting the software they will lose their position? 

On this project i am trying to mark with precision the boundary of the building, but then i need just the polylines of the roads and the paths with “no precision”, so i don’t need to mark the points on the image but it’s sufficient to have the position on the mesh…

This is the situation i need… i exported the polylines (lines and verticles), but if i save and close, the situation is…

and i’ve lost all the polylines i’ve created… because the computed position of all mtps without any mark on the photos had a reset… All mtps have the same computed position in the middle of nowhere… Why?

Hi Nikolay,

If you follow the same procedure as with the cameras but with one the MTPs missing in the rayCloud view, you should be able to focus on the polylines. It seems like the model (images) are at one place and the marks of several MTPs are in another location.

This might be geolocation problem. There are three coordinates system, that of:

  • The images
  • The ground control points (GCPs)
  • The outputs

Did you change the coordinate system? Could it be that you first defined the image coordinate system, ran step 1, marked the MTPs and then modified the coordinate system of the images? It would mean the MTPs are stuck in the old reference system.

For more information about changing the different coordinate systems: https://support.pix4d.com/hc/en-us/articles/202560029

Regards,