Support Website Contact Support Blog

Black screen after initial processing, raycloud is not displayed

I am for the first time needing to do some volumetric measurements of coal stockpiles.  I have ran the initial processing and entered my GCP’s (5 of them) and when initial processing is finished I only have a black screen on the rayCloud.  Not sure what to do?

Do you have the OpenGL 3.2 driver? The rayCloud needs it to show the 3D data but you would have gotten a warning message. Double check your project log file for an error and it might tell you if that’s the problem.

I have also been having the same issue, I think it has something to do with the raycloud loading properly. I found that if I just did all three parts of the process I could then go to Volume and go back to Raycloud and it would load. Also been having raycloud vanish on me when I try switching to track ball navigation.

Hello Brock, hello Matthew, hello Scott,

What might happen is that the screen is not focused on the project and the point cloud is located somewhere else.

You can try to select an automatic tie point on the left sidebar and press the key “F”

(or select rayCloud -> Viewpoint -> Focus on Selection). This will focus on the point cloud and might find the lost point cloud.


Otherwise, it might also be that the GPU does not support OpenGL 3.2 as @Matthew said, in which case you cannot see the rayCloud.

Check the system requirements here:


Best Regards, 

I have the same problem, when switching to trackball the hole trackball goes up to the right corner, and if I try to focus on selection it does, but still the trackball is located upper corner right, it  is very hard to work with. I want to have the trackball in center.

This goes for every project i have, always the same location.

Is there a solution to this?

Look at picture, it is lioke this in every project.

Please help me :slight_smile:

best regards, Simon

Pix4D support!

Could you please answer on the trackball in center issue ?


Hello Liss, 


Can you please give us some information about your project? What is the output coordinate system?

Are you using multiple screens by any chance?

Try to remove the trackball and  click rayCloud > Viewpoint > Focus on selection.


Best Regards, 

I work with a two screen solution, and when the pix4d was in the big screen, the “univers” with the trackball seemed to fall out of senter. But if you go to the screen preferanses, you only have to find the right screen settings.



I was having the same trouble.  It seemed as though my origin was right of center and moving the project around (and finding it) was a challenge.  By dragging the Pix4D window onto my main screen, this immediately corrected itself and everything was working normally. 

I didn’t even know how to search for this “out of center project” but fortunately found this thread.