Support Website Contact Support Blog

Pix4Dmapper Pro Trial - Software "Not Responding"

I recently purchased a high end (Desktop Replacement) gaming laptop. Specs below.

Asus G752VS Laptop, Windows 10 Pro (x64), 2.70 gigahertz Intel i7-6820HK processor, Nvidia Geoforce GTX 1070 graphics card, 64GB RAM, 512GB SSD and 1TB 7200RPM HD internal drives.

I am new to Pix4D. I regularly use DroneDeploy. I have been trying to run a trial version of Pix4Dmapper Pro. I have had 1 successful completion out of a dozen or more attempts with 3 different projects. I have tried 3 different versions of the Pix4Dmapper Pro software including 3.2.23, 3.3.7 and 3.1.23 . I have also tried running the software as an Administrator. Unfortunately, I have not been able to install the software as an Administrator. Nearly every time now the Pix4Dmapper Pro software will immediately go to “Not Responding” or at some point during the process. There still seems to be a pix4dmapper process running and I can see processor, disk and GPU activity but the interface stops responding.

I have run full diagnostics on this hardware multiple times with no issues found (all passed). As far as I know, all software, drivers, etc… are up to date. I have had no problems with the hardware and all other software applications run fine, expect Pix4D Mapper Pro.

I have sent support many notes with screen captures and other information they have requested (if available). So far not much help from Support.

Any suggestions/recommendations?

Thanks,

Mike

 

http://www.geoimagingtech.com/ 

Asus G752VS Laptop, Windows 10 Pro (x64), 2.70 gigahertz Intel i7-6820HK processor, Nvidia Geoforce GTX 1070 graphics card, 64GB RAM, 512GB SSD and Seagate FireCuda Gaming SSHD 2TB SATA 6.0Gb/s 2.5" internal drives.

All Windows 10 and Application software/drivers, etc… are all up to date and current.

This is Mike Allison once again. I have tried using a trial version of Pix4D Desktop once again on my high end gaming laptop (specs above) with inconsistent results. I was able to successfully process several projects on this laptop. After that, Pix4D would stop responding (locking up? or not responding) just prior to beginning processing. Since my last successful project, Pix4D has failed every time since.

Acer Aspire E15, 15.6 Full HD, Intel Core i7, NVIDIA 940MX, 32GB DDR4, 256GB SSD, Windows 10 Pro, E5-575G-76YK

I did decide to run Pix4D on my Acer Laptop (specs above). So far the project I started is processing fine.

Is there a potential compatibility issue between Pix4D and  the Nvidia Geoforce GTX 1070 graphics card (pretty new) on my high end gaming laptop? If I am to use Pix4D in production, I need to get it working consistently on my Asus G752VS laptop.

Hello,

As far as we know there is no compatibility issue between the Nvidia Geoforce GTX 1070 graphics card and Pix4D Desktop. Many users have successfully managed to process their projects using this GPU. Please make sure that the latest GPU drivers are installed.

However, to confirm that there is no issue with your graphics card you could try to disable it from the processing options and process a project. To do this you open the processing options window and in the Resources and Notifications tab you deselect the GeForce GTX 1060 option. Processing this way will take longer, but could you please give it a try and let us know about the results?

Additionally, you could maybe try to change the workspace of the project, e.g. from C to D drive. We also highly recommend not to have other applications running in the background as this can overload the processor and cause the crashes.

Regards,

I used to get the “not responding” hang all the time with my MSI i7-6820 gaming laptop with dual GTX1070 cards.  The Nvidia drivers and PIX4D fight each other for resources, most notably RAM.  As I cannot get PIX4D configured to use more than 40GB of RAM, I knock down the RAM usage in the resource settings to 56GB from 64GB.  This resolves the “not responding” hang that while it’s visible as “not responding,” it’s responding just fine. People tend to jump the gun and close out the program thinking they have to start over. Be sure to go into your task manager and set the program priority to either “low” or “below normal.”  The program sometimes defaults to low and other times it doesn’t.  Set your priority to one step below where it’s at and lock it in.

I was having an issue with the program altogether crashing between step one and step two.  For some reason when the program finishes step one and transitions to step two, it finds and hogs EVERY resource.  I’m running full resolution processing on 1290 photos right now and to avoid the annoying crash, I just uncheck the boxes for step two and three when beginning the process and perform each step individually.  

Another instance that hangs the program is when you use the Intel Boost Utility.  Don’t use it.  If you want to overclock your rig, do it from within the BIOS.  Regardless, if the program just indicates “not responding,” leave it alone until it either finishes the step or crashes.  I had one instance where it was “not responding” for 30 hours and then all of the sudden, all the processing showed complete with quality reports popped up.  

If you’re going from Drone Deploy to PIX4D, the results will be comparable to going from playing Bally Pong on Grandma’s basement console B&W CRT TV to playing PS4 COD MW on a 70" 4K flatscreen.  It’s just that good.

3 Likes