Pix4dmapper crashes and event viewer points to ucrtbase.dll

Quite troubled with installing Pix4dmapper (4.7.5) on my brand new laptop running Windows 10. This is what it says in the Pix4d_mapper_log.txt-file:

Szint Dátum és idő Forrás Eseményazonosító Feladatkategória
Hiba 2022. 02. 24. 10:08:08 Application Error 1000 (100) "A hibát okozó alkalmazás neve: pix4dmapper.exe, verzió:, időbélyeg: 0x619f5b1a
A hibát okozó modul neve: ucrtbase.dll, verzió: 10.0.19041.789, időbélyeg: 0x2bd748bf
Kivételkód: 0xc0000409
Hiba pozíciója: 0x000000000007286e
A hibát okozó folyamat azonosítója: 0x1c3c
A hibát okozó alkalmazás indításának időpontja: 0x01d8295e09bb8a46
A hibát okozó alkalmazás elérési útja: C:\Program Files\Pix4Dmapper\pix4dmapper.exe
A hibát okozó modul elérési útja: C:\Windows\System32\ucrtbase.dll
Jelentés azonosítója: 9e7b9983-95d1-4527-83c0-528d174b7ccf
A hibát okozó csomag teljes neve:
A hibát okozó csomag relatív alkalmazásazonosítója: "

Tried reinstalling. Tried removing app. Tried updating all drivers. Restarted inbetween. Turned off Windows security. Also turned off the firewall. Running sfc/scannow with no integrity violations. Played around with the timezone seetings. Nothing.

Had hoped it would be possible to download an earlier version of the software. Not an option it seems.

I have seen many several people having this problem in this forum. No clear fixes.

Any fixes?


The issue you describe is usually due to an antivirus program blocking PIX4D. Can you temporarily disable their antivirus program or whitelist PIX4D as safe.

The issue could also be caused by a conflict in the ‘proj_lib’ environment variable. Pix4d uses the GDAL library. If you also have installed GIS related software which also sets an environment variable ‘proj_lib’. After removing the environment variable, Pix4D might not have any issues.
Here is also a link describing how to delete the projso and proj_lib environment variables


1 Like

In this instance it looks like it was a proj_lib variable conflict. I am running PostgreSQL (PostGIS) on my laptop, and it had set PROJ_LIB to “C:\Program Files\PostgreSQL\14\share\contrib\postgis-3.2\proj”.

I would recommend you either solve this “back office” programming around the issue or at least log the error in a clearer way. The current error message is not readily available (windows log) and certainly not clear.

In any case - thank you for a good answer to my problem! Pix4D mapper is up and running now.

HI @ragnvald ,

We really appreciate your feedback.

I will pass your suggestion to our developers and even though we cannot guarantee that a solution will be implemented, I can assure you that every piece of feedback is internally evaluated at Pix4D.

We appreciate the time you took to share your feedback and we are glad your issue got resolved!


This needs to be put on a sticky somewhere, this has been an issue for me for awhile, and getting rid of that variable worked. I can finally run the newest Pix4D.

1 Like

Hi @survey7,

There is also this link describing how to delete the PROJSO and PROJ_LIB environment variables.


HAve tryed it with no succes!

The problem returned so the solution indicated did not last. I have basically had a license for your software for 6 months now without being able to use it. It does not work for me to edit the registry to be able to run the software. Should be fixed.

It is not like it is being continously updated. Last update was version 4.7.5 – Nov 25, 2021.


We are very sorry to hear this.
I will pass your feedback to the product team.

Please contact us with a support ticket if you still have an issue with your license.
We will need to ask you questions about your license and PC configuration that should not be posted here for troubleshooting.

Just for you to know, there are more updated versions of PIX4Dmapper after 4.7.5 – Nov 25, 2021.
You can check the following article for more information: PIX4Dmapper release notes

Have a very nice day!

Best regards