Support Website Contact Support Blog

Pix4Dmapper 4.3.31 crashing

Roughly 75% of the time, since updating to 4.3.31, that I am processing an image set, Pix4D freezes my entire system, forcing a hard reboot. The issue occurs in the 2nd phase of initial processing, when analyzing automatic tie-points. Is anyone else having this issue, does anyone have a fix?

Hi,

Can you check if your graphics card driver is up to date? Very often outdated drives cause the crashes. 

If it won’t solve the issue, please submit a ticket to Pix4D Support and we will investigate the issue :slight_smile:

Best! 

All drivers are up to date, verified today.  If/when the issue occurs again, I will submit a ticket to Pix4D Support at that time. Thank you.

OK, let us know how is goes!

If you will decide to submit a ticket don’t forget to send us all the necessary files; spec of your computer and project files.

Thank you,

Cheers!

I’m experiencing the exact same issue.  Latest drivers, etc.

I´m another one having the same issue, but on the computing keypoints, the software freeze. Never experienced these issues in the past. Please Pix4D, can you investigate and let us know why this is happening.

Thank you,

 

Hi all,

We would need more details to provide assistance in the most efficient way. Could you please submit a request to Pix4D Support and send us the following?

▸ The quality report (.pdf format): …\project_name\1_initial\report\project_name_report.pdf (if any)
▸ The project log file (text file): …\project_name\project_name.log
▸ The project file (.p4d): …\project_name.p4d
▸ One or several screenshots of the 3D rayCloud view.
▸ Description of the steps before receiving the error.
▸ A screenshot of the error pop-up or at least content of the message.

Additionally, please send us the machine specs:

  1. Click the Windows Start icon and type System Information. Select the application in the list above.
  2. In the application, click File > Save… and export the content.
  3. Attach the file your_file.nfo to the reply.

Thank you in advance!

I believe I determined the cause of my issue.  The machine having an issue has a Threadripper processor, 128GB RAM and a Ti GPU. We initially had it overclocking, but the issue went away when we disabled the overclocking.  Runs slower, but at least it runs.

I am experiencing the multiple crashes for step1 and merging of projects. Since then I reverted back to 4.2.27 and not bother using 4.3.31. You guys miss test cases in your QA.

Hi,

If you are experiencing software crash during step 1 it is very likely that you are dealing with the following problem [Desktop] [Pix4Dmapper 4.3.31] Processing issues during feature extraction in Step 1. If it is not a case please submit a ticket to Pix4D Support and we will help you by investigating the issue. 

Best