Support Website Contact Support Blog

Pix4DCapture + ZenmuseXT - Image Acquisition Timing Interval Bug

I have been having a big problem with the last few recent version of Pix4DCapture for Android when using the ZenmuseXT thermal camera on the DJI Inspire1 airframe.

It appears that the image acquisition timing interval has been messed up.  After every mission there are only like 1/4 to 1/6 of the expected images but in these cases the images are evenly spread over the flight path so its not the case that something is interrupting the capture mid flight.

For example I had a flight the other day at 120ft 90deg 85% overlap.  After the flight Pix4DCapture app indicated that there should have been 214 images taken but there was only 64.  Of importance to note is that the images that are taken are evenly spaced across the flight path which is why I believe is it an issue with the interval timing.  Attached are images of the Pix4DCapture screen and the resulting images opened in Pix4DMapperPro.

Since there are much less photos than expected the overlap is awful and produce awful results in Pix4DmapperPro.

I get this type of result with the ZenmuseXT at every altitude, overlap and flight speed combo I have tried.  This only happens when using the ZenmuseXT camera.

So anyone at Pix4D able to comment?

Hi Brad,

Thank you for the detailed feedback.

It is indeed strange that images are missing but that the saved ones are evenly spaced. Are the images imported to create a project those found on the device and/or the SD card of the drone? Could it be that all the images are on the SD card, but only one out of six is transferred to the device?

Also did you have the chance to fly with the latest version of the app that was released last week?

We recommend this article to troubleshoot app issues and proceed with basic checks before further investigation:
https://support.pix4d.com/hc/en-us/articles/115004119343

If the issues persists, please contact us via the request form and attach the log files.
How to extract: https://support.pix4d.com/hc/en-us/articles/215281483

Yes the problem remains with the latest version.  

I just did another 3 complete flights today and same issue (also a couple dud flights that I had to abort after Pix4DCapture would crash during flight).  

Pix4DCapture indicates there should be ~130pics/flight but the SDcard has only ~24/flight.  Again the images that are there are sequentially numbered and equally spaced over the flight plan but instead of 85% overlap its like 5-10% overlap.

I will send my log files to support.

Here is a snippet from the ctrl_dji.log that looks interesting.  

2017-09-15 12:59:15.745 [Thread-11529] DEBUG com.pix4d.plugindji.a - createCameraGeneratedNewMediaFileCallback triggered: DJI_0054.tiff (id: 99954) with timestamp: 2017-09-15 12:59:07 (now: Fri Sep 15 12:59:15 PDT 2017)
2017-09-15 12:59:15.753 [pool-56-thread-1] DEBUG com.pix4d.plugindji.a.f.k - Interval triggering photo simulation was already started.
2017-09-15 12:59:16.021 [Timer-8] WARN c.pix4d.libplugins.plugin.command.a - Server not started. Ignoring: PICTURE_TAKEN
2017-09-15 12:59:18.020 [Timer-8] WARN c.pix4d.libplugins.plugin.command.a - Server not started. Ignoring: PICTURE_TAKEN
2017-09-15 12:59:20.020 [Timer-8] WARN c.pix4d.libplugins.plugin.command.a - Server not started. Ignoring: PICTURE_TAKEN
2017-09-15 12:59:22.020 [Timer-8] WARN c.pix4d.libplugins.plugin.command.a - Server not started. Ignoring: PICTURE_TAKEN
2017-09-15 12:59:24.020 [Timer-8] WARN c.pix4d.libplugins.plugin.command.a - Server not started. Ignoring: PICTURE_TAKEN
2017-09-15 12:59:25.649 [Thread-11677] DEBUG com.pix4d.plugindji.a - createCameraGeneratedNewMediaFileCallback triggered: DJI_0055.tiff (id: 99955) with timestamp: 2017-09-15 12:59:12 (now: Fri Sep 15 12:59:25 PDT 2017)
2017-09-15 12:59:25.654 [pool-56-thread-1] DEBUG

Hi Brad,

We checked the .log file with developers and noticed that there is a bug on our side. Thank you for reporting it.

At the moment the case is under investigation and it is hard to predict when it will be resolved. To get the latest updates about new features, bug fixes and improvements you can follow the technical release notes.

As a side note, this bug only affects the Android version. It’s nevertheless working fine on iOS.

 

Best,

Thanks for keeping me updated.

I just wanted to refresh this topic as this issue still remains almost 1 year later in the latest versions of the Android pix4dcapture software. 

I just spent a day flying multiple missions with the ZenmuseXT on the Inspire1 and it continues to take a fraction of the expected pictures.  The pictures it does take remain evenly spaced like it actually takes every 4th pictures it thinks it takes.

I tried many combinations of overlap settings and flight speed to see if a user setting could be triggering the bug but it seems unrelated. 

 

The issue should be fixed in the version 4.2.1 that was released in May. As a side note, we recommend using the SD speed class 4 or higher to achieve the desired triggering interval.

More information in the (Android) Pix4Dcapture release notes.

Maybe it should be fixed but it does not appear to be actually fixed. 

I am using the newest version of the software as stated in my post, and I am using the same class10 microsd as I use with the ZenmuseX5 RGB camera that has no issue saving much larger 4MB files every couple seconds (XT’s image files are only ~650kb). 

Prior to ~July2017 versions of Pix4DCapture there was no issue so I think it is a software issue and not a hardware issue.