Support Website Contact Support Blog

Pix4DCapture Unable to find images taken

 I’m sorry if this is posted elsewhere, but I’m brand new to this app–literally, uploaded it on Wednesday, and I’m about to leave my office for a few days so I have to type this fast.

So I use this program for work, and we just tried it out for a first “mission”–short, five or so minute grid flight. We use an ipad to control our drone, and out in the field we don’t have wifi, so I couldn’t log in. I still have a few “skips” left for this, however, so I skipped the log in process and simply planned the flight and then flew. Flight went fine, but then 3/4 of the way through it started raining pretty badly. The moment it finished flying, we turned the drone off to cut potential damages, dried everything off, etc.

Back at the office, I connected the camera’s memory card to my laptop, but found no pictures from today. I put the card back in the camera and powered it all on again with the ipad connected to the controller & talking to the drone, searched in the “mission manager” section of the app and found absolutely no record of the flight we flew this morning. Couldn’t sync, obviously :frowning:

What gives? I can think of a few potential reasons for this, but I don’t know which one is right or if any of them are right: 1) we weren’t logged in so the pictures didn’t save; 2) we didn’t have wifi so the pictures didn’t save; 3) we turned off the drone & controller too soon after the flight for anything to be saved; 4) the app didn’t take pictures for some reason I don’t understand; 5) there are pictures but they’re floating around in cyberspace somewhere and I don’t know where to go to retrieve them

The rain does not appear to have damaged anything, so I really don’t think that’s the problem.

I really need some help. It’s not a big deal if I can’t retrieve these images–I just want to know how to do it correctly for next time. Thanks in advance for any assistance!!!

OK correction: now the mission is showing up under “Mission Manager” but it says “Error” and there aren’t any images attached at all. Any ideas??? Please???

Hello Sara,

Internet connection is not needed to start a mission or during the mission. It is only needed the first time that the app is opened to get the DJI SDK, from time to time when opening the app to get again the SDK, to display the maps in the background and to log in the application. After the mission is completed Internet connection is needed to upload the mission to the cloud. Moreover, rain should not be the problem in this case.

When the connection between the drone and the phone is lost it is possible that images are not taken.
The interactions between the drone and the app during a mission are as follows.

  1. The app receives the GPS location of the drone (drone >> phone).
  2. The app decides to take a picture according the new location, and asks the drone to do it (phone >> drone).
  3. The drone may or may not take a picture, even though usually it does.
  4. The drone sends back a message to say that the picture was taken (drone >> phone).
  5. The app shows the camera icon at the position of the drone when the message is received.
    Could you see the camera icon on the flight track during the mission?

Could you also make sure that the option JPG+RAW is not selected in DJI GO? It can happen sometimes that the image capture fails when this image format is selected in JPG+RAW.

Regards,

I had exactly the same problem.  I’m also new to this software. I used an iPAD Air 2 and a Phantom 4 and I did two little double grid test runs and then went home later to find that no photos were taken at all.  It recorded that I created two projects but there are zero images.  A little frustrated as I was hoping to see what the 3D model would look like but oh well…

I just checked the photo setting in the DJI GO app and it was set to JPEG only.  This has now been changed to RAW so I will try and repeat the process a little later and see what happens

 

1 Like

Hey Chris,

Sorry to hear that you had the same problem! In my case, I’m pretty sure that what happened was that I didn’t close the DJI Go app prior to flying my Pix4DCapture mission. Apparently the two apps can’t run simultaneously. Not sure if this is your problem of course, but maybe  something to keep in mind for next time. Hope that helps.

Sara

I have the very same problem going on.  I was demonstrating for my brother and he works at Boeing in Seattle.  All of my flights are no where on my SD card.  This is not good.

You can refer to these posts for the issue you described:

(Android) Images are not captured
(iOS) Images are not captured

Hello Julie, 

 

similar problem here. flew the Phantom4 with iPad2. No other app wa open, but P4D Capture. after the mission, it says 245 pictures were taken on a grid mission. After the mission the app tried to download the pictures, but progress bar didn´t move, so i had no option, but to shut everything down.

At the office, I connected the iPad to the controller, and powered up the DJI. The mission is still there, but when I try to download the photos via the app, nothing happens, and after a while, it says “error downloading the images”.

 

Please tell me if there is any hidden directory in the P4 where I can find the photos , and what happened.

 

Thank you!

Hi Manuel,

Have a look if there are some images stored on the drone’s SD card. If not, then the images were most probably not taken and you will need to re-fly the mission.

Main thread about this issue: (Android, iOS) Imagesarenot captured.

Best,

pictures were there, but could not be synchronized. different flights, all with same result. not synchronizing images after flight. any idea?

As for the download to device and upload to cloud post-flight procedures, they might fail from time to time.

We believe that this is not a systematic problem since it is not possible to reproduce it. It might be unstable in some cases. Once it fails, it happens that it cannot be initiated again and become successful.

There is, for now, no other option but to extract the images from the SD card of the drone and create a new project from scratch.

As a side note, images are directly geotagged by DJI so there should be no difference if you process the project with the .p4d generated by the app or if you create a project from scratch.

Same thing for me.  No sync after mission.  First time user.  Photos on SD card but failed to upload.  Showed error that mission had not yet been flown.  Eight or so times attempted.  

Phantom 3 Standard, iphone 6 64gb with about 34gb memory remaining.  

I am not sure about difference between safe and fast.   Is one or the other required with the wifi based P3 standard?   If all expected images are on the sd card, safe/fast would not be the issue, right?

I did have a problem on first mission attempt getting through take-off check-list.  Kept telling me to put the S1 switch to ‘P’, which I did on several take-off attempts.  Clicking the orange told me possibly not enough GPS in view.  The checklist reported GPS ok.

I re-loaded DJIGo. I said 11 sats.  It flew fine.  I killed DJIGo and tried Pix4D missioln take-off again.  Same deal, bad checklist, no take-off because of S1 switch error even thought in S1.  SO, I re-loaded DJIGo, went to hover for a few seconds, landed, closed DJIGo BUT DID NOT kill it this time, reopened PIX4D, and got through the take-off checklist and flew the mission and got the nadir double pix onto the SD card, only to fail to sync the images back to the phone at end of mission.  After I finally got the first take-off, I was able to fly several other missions, grid, circle, free flight with and without DJIGo alive in the background.

I am pretty sure I got about 6 good missions,  all got images onto the sd card.  

I just looked in settings and 'Auto download images when mission ends was NOT ‘On’.  But I did attempt to sync by touching the on screen prompt on this missions that I had flown and that had reported had images.  Every sync attempted from the mission failed with the report that the mission had not yet been flown.  After each fail attempt to sync a mission that reported images in image (i.e.: 0/30, 0/64 synced (download, whatever is says) showed 0/0 mission not yet flown after the failed sync attempt.

One other question, how do I delete a mission off of my iphone from mission manager.  Most where just testing how to create a mission and I don’t want or need them.

I have an IPad mini 4 with 128gb memory dedicated for my Phantom.  I have an Android Tab 8 also.  I will attempt more missions with these.  I would prefer to wait for the reply to this before attempting any more missions.

I will sit down now and attempt to process the missions manually at the desktop.  I have been watching the tutor vids and hope I can figure it out. 

My test subject is a 100’ high water tower with a big, round concrete base and a large bright white metal tank with a large blue city banner painted on both sides and some machinery and catwalk detail on top.

I have already parsed out the bad images and separated high and low circles and double-grid missions into separate file directories and sprinkled in a few ‘free flight’ connectors.  We’ll see how it goes.

I am looking forward to seeing your PIX4D applications work.  I intend to subscribe to the $50 a month Basic program if it does.  I am a hobbyist who is fascinated with the potential of 3D modeling from drones.

Yours seems to be the only image program that supports (tolerates?) the wifi based Phantom 3 products.  I am not in a position to go out and spend another $1000 bucks and subscribe to a $100 a month or more program, especially since those others give the user no ability to edit, clean up, the image sets to improve the final model.  PIX4D looks like fun.  In fact, if this works, I am going to purchase a GoPro 5 to be able to add ground level images to models.

Thank you,

Marvin Hesket