Support Website Contact Support Blog

no photos on sd card after mission

Hello,

I am using a ios 9.3.2 on an ipad mini, a DJI 3 advanced and Pix 4d capture version 1.2.2 (2). After flying a grid mission that seemed to work well I discovered no photos on the sd card. Is there something I am missing? This has happened on all 4 missions. Thanks for any help.

Hello Bill,

I have some questions for you that could help me understand more about what happened.

Was the SD Card empty when you started the first grid mission?

Did you notice any alerts/errors related to SD card while setting up the first grid mission? The App checks the status of the SD card when it connects to your drone and reports it in the telemetry panel:


Status of the SD card. The status can be:

  • Ready
  • No SD card
  • SD card full
  • SD card unformatted
  • Has error
  • Unknown SD card error

 

If the status of your SD card was correct, did you try to synchronize the images with your iPad at the end of the mission? Did you get any error when the synchronization started?

With Capture App the images are automatically synchronized at the end of each mission or from the mission manager panel, depending on what you have selected for the general setting “Sync automatically”:

When this option is enabled, the missions are automatically synchronized from the drone to the device at the end of the mission. By default the option is enabled. If the missions are not synchronized, they can be synchronized later on following: 204057579

Lastly, Pix4Dcapture 1.2.2. is the latest iOS version for P3A and is recommend to make sure that:

  • The manufacturer’s app (DJI GO) is not running in the background especially after connecting the device to the drone. Also check that this app is not selected as the default app when connecting.
  • The appropriate drone is selected, please see: Settings of the app: Home screen > Settings > Drone type > …
  • The latest firmware is installed on the drone. Please check it with the manufacturer’s app.
  • The latest OS version is installed on the mobile device.

Regards,

Mattia

Thanks Mattia,

The only item that you mentioned that I did not do is to shut off DJI Go. All of the other items are up to date. I received no error messages except when looking at the mission manager, there was “error” next to the mission name. 

I have a few questions about the GO app: 1. Should I use the GO app to verify the drone at the beginning, calibrate and then shut off the app? 

2. then Start the Pix4d Capture.

Regards,

Bill

Hello Bill,

what’s recommended is to make sure that DJI GO is not running in the background. You can use it to verify your drone and for calibration as long as you’re closing it prior to start Pix4D Capture.

I hope this will help.

Regards,

Mattia

 

 

I will try that this evening. I also formatted the sd card to make sure. I will report with the results. Thanks.

Bill

Hello everyone, 

 

I had the same problem, no pictures appeared on the drone SD card nor on the device where I used Pix4D capture. However, when I open pix4d capture on the device, and select my project from the project list, I am able to see my missions containing images that I am supposed to be able to download, but when I try to there are some errors popping up related with the Pix4D Capture or the Ctrl+DJI apps, and the dowloading process is unable to continue.

 

I am wondering whether 1. Is  there any way I can have access to these images,  and 2. The place where these pictures are stored.

 

I would greatly appreciate any help regarding this issue.

Thank you so much in advance, I am looking forward to hearing from you soon

Luis

 

 

Hi Luis,

We are aware of the issue and our team is looking into it in order to find a solution. You can find the post here.

Double check if the images are stored on the SD card of the drone. If the images are not saved on the SD card then they were most probably not taken. 

Best

Dear Blaz

I have checked the SD card multiple times and find no images at all. As I wrote before, the images seem to be somewhere I cannot have access, but images appear associated to the mission of the project even if they are not on the SD card or the device memory, see the following picture

Anytime that I try to download them, Ctrl+DJI stops working and I cannot continue with the downloading process, see following picture. That is the reason I wondering where are them, is that a kind of a hidden cloud?I really do not understand what happens

 

 

I tried what was recommended to do in the forum: deleting the cache memory of the Ctrl+DJI app, or installing it again, but still not working.

Could you please shed some light on this?Is there any other way I can have access to the images?

Thank you so much for your help, I am looking forward to hearing from you soon

Luis

 

 

 

 

Hi Luis,

It seems like the images were not captured so they cannot be found on the SD card or on the device, even though the camera icons are displayed on the map. Therefore, the download fails because Pix4Dcapture calls for images that do not exist on the drone’s SD card.

To avoid this problem next time, please refer to my comment here. Note that it is not possible to recover the mission and that you unfortunately need to fly again.

Also make sure to proceed with basic checks before flying. Hope it helps! Let us know how it goes.

Dear Julie, 

Actually I could download the images, even if they were not on the SD card nor on the internal memory of the device, that is the reason why I was asking you were are they stored, or how can I have access to them. The problem is that after dowloading the half of the mission, the app Ctrl+DJI suddenly started to stop working, and I could not continue with the image downloading. I deleted the chache memory of the app, and even installed it again, but the problem persists.

I am very surprised cause the images are somewhere stored, and I could download them if it wasnt for the continuos crashing of the Ctrl+dji app.

Has this issue ever happened to anyone? 

Thank you

Dear Luis,

If the images were not saved on the drone SD card, there is no chance that they were downloaded as they were not even captured. From the previous screenshots, it does not seem the images were downloaded ( 0/375 ). This is why Ctrl+DJI stopped working as the download fails.

Images must first be saved on the SD card of the drone before being downloaded, meaning the images are transferred from the drone to the device.

Does it answer your question?