Support Website Contact Support Blog

Pix4Dcapture no longer opens ("keeps stopping") after aborted mission

Last weekend, I flew two missions with my new Mavic Pro. A few mistakes were made on my end, I admit, but I cannot figure out how I ended up breaking the Pix4Dcapture app on my LG G5 Android phone.

I will describe what went wrong with those flights, but the current status of using Pix4Dcapture is this: the app crashes after A) I try to open it or B) I manage to open it and then hit ‘Projects List’. Even more strangely, I managed to make it work once this afternoon, but only by selecting “Use Pix4Dcapture with this device” when prompted after plugging my phone into the Mavic remote controller. It executed that mission today flawlessly (processing it now) and returned to home with no problems. Thought it fixed itself but when I went to open the app from my home screen, same error “Pix4Dcapture has stopped working/keeps stopping”.

Upon landing after the mission completed, my phone died during the “download to device” process that says it should not be interrupted. After recharging and restarting the download process, my phone was overstuffed with 200+ jpgs and prompted me to make some space. Any apps I tried to open before deleting making room on the phone’s storage would crash.

This turned out to not be much of a problem since I was able to retrieve the images from the UAV and processed them successfully later on.

I have uninstalled and reinstalled both Pix4Dcapture and Ctrl+DJI apps only to have the same result. I really enjoy the Pix4D platform and want to continue, but desperately need help. 

Thanks and I hope you all have a solution for me!

Hi Benjamin,

My understanding is that you have already uninstalled and reinstalled Pix4Dcapture and Ctrl+DJI but found that Pix4D still fails to launch. I anticipate that Pix4Dcapture is failing to launch because the app’s project directory was corrupted when your phone’s battery died while downloading images via the remote controller.

Please uninstall Pix4Dcapture and Ctrl+DJI, and then delete the Pix4D directory that you find on your LG G5 Android phone. Reinstall Pix4Dcapture and Ctrl+DJI then take it for a spin.

For future flights, I recommend that you disable the automatic syncing of your images after each flight. You’ll find that transferring your images directly from the SD card is generally faster and does not require any additional battery life.

Let us know how it turns out.

1 Like

Thanks Andrew!

Haven’t run a mission on it yet but it definitely appears to be solved i.e. the app opens fully instead of crashing upon initializing! I had thought I would need to delete that directory but wanted to hear it from someone who knows more than I before I went ahead rooting around in my device! 

Really appreciate the help with this. I love using the software!

Benjamin,

Glad to hear that you are back up and running. Don’t hesitate to create a new post in our Community if you have any questions.

1 Like