Support Website Contact Support Blog

[Pix4Dcapture Android 3.8.4] Feedback and experience

Hello Pix4D members and Android users,

We are glad to announce a new version of Android Pix4Dcapture!

Please use this post to share your experience with other users and us.
We are looking forward to your feedback!

Pix4D Support Team

Hi, 

Is it possible to use a shapefile or KML file overlayed on the basemap with Pix4d Capture?

I’ve tried using a tiled map service url (I made of our property lines in ARCMap and shared to my Arcgis online account) as the street basemap provider in the main screen settings. It gave me an error about x, y and z parameters (see screen shot below). I just added /{z}/{y}/{x} to the end of my url and it accepted it and let me save it. But my property lines don’t shows up in my mission planning. The other imagery from “Satellite basemap provider” or a blank grid. Kind of sucks since I had to use credits to upload my tiled map service.

I noticed DroneDeploy now allows you to import .shp and kml files with an app you download through their app market on their opening screen. It even automatically draws the mission plan. Will only do one polygon even though your .shp file has more.

I choose to use Pix4d because it: 1) does the double grid mission. 2) Orbit mission w/ cool settings like angular capture. 3) Free flight mission w/ picture every horz+vert distance

Things I would like to see:

  1. Import .shp and KML files. Be cool if it automatically drew missions like DroneDeploy, but unlike them in the way that it could handle multiple polygons. Then choose which property to fly and auto mission.

  2. Battery settings to allow for it to return home later than 15% (more like 8%) and later warning of 25% (more like 15%)

Thanks, Alex

Hi Alex,

Thank you for the very nice feedback.

1. You can already import a .kml (.shp file solely) or .kmz (.shp file plus .tiff/raster file) to plan your mission, this article will probably help :). This is indeed, very useful if the base map is not updated or missing in remote areas. But it is then necessary to design the mission manually (altitude, overlap, camera angle, etc.). Also the polygon mission is under development on Android.

2. The RTH option should work but it is a setting to tweak in DJI GO (4). Then if the signal is broken between the drone and the remote control for 3 seconds or if the battery level drops down a certain level, the drone should automatically abort the mission and come back to the home point (where it was turned on). You can define the battery level on DJI GO (4).

Regards I have been using pix4d capture since March 2016, with Phantom devices, 3 pro and 4, now We have a Matrice 100, this last update doesnt let the drone fly up to 10m/s, it perform a mission to 5m/s, I have a device with version 3.3.1 and in it the matrice perform 10m/s on a same mission flight. 100m altitude 80% overlap 550x550 14 minutes mission.

 

Could you check this issue please?

 

We test with 3 mobiles devices, the same mission on two different devices one asus and one samsung fly 5m/s with APP version 3.8.1, two flghts with moto g4 plus APP version 3.3.1 10m/s.

 

Thanks.

 

Now We are performing several tests with zenmuse X5 cause in the first test flight we noticed a trouble with the camera focus, the image and the orthomosaic was too blurry.

Hi Juan,

Versions 3.3.1 and 3.8.1 do not rely on the same picture trigger mode.

 

In the latest version, the action to shoot a picture is based on a time lapse. The app requires to be connected to the drone time to time to get a feedback about its position. The drone cannot fly to fast otherwise the time lapse is too short and the drone will miss images.

 

In the older version, the app sends a signal when to shoot. It requires the connection with the drone to be maintained without interruption. It is solely based on the position of the aircraft. This mode was actually less reliable because images were often missed.

 

Hope it clarifies the situation :).

When will we see the features and functions be the same between iOS and Android?  Making a polygon grid mission is a major item missing here.

Hello all…

I’m using Infinix Zero 4 Plus for monitoring my drone. My drone is P3 Advanced. It works well with DJI Go, live stream is good.
But when I’m using Pix4D capture I think there’s something wrong. In order to control the drone, the app needs Ctrl+DJI plugin. I have installed that plugin, but whenever I start Pix4D Capture, the app always ask for plugin installation although I have installed it. I think that’s the problem. A temporary solution for this is I start the plugin, and then start the app. I have tried for many times but only 2 missions were accomplished. Anyone face the same problem?

Please share your experience.

 

Cheers

Hi Husnul,

Thank you for sharing your experience and the workaround.

Could you please confirm:

  • The latest versions of both Pix4Dcapture and Ctrl+DJI are installed.
  • The latest DJI GO version is installed.
  • Latest firmware is installed on the drone and the remote controller.

Also:

  • What is the Android OS version of the phone?
  • Did you try to log in the DJI app and connect to the drone before opening Pix4Dcapture?
  • Did you make sure DJI GO is not running in the background when starting with Pix4Dcapture?
    https://support.pix4d.com/hc/en-us/articles/209626486

Hello Julie.

I’m using P4D 3.8.1 and ctrl dji 1.6.1. I installed DJI go 3.1.8. I did not found the info about firmware, but it has never been updated. It’s still working.

I’m using android 6.0. Everytime I start connecting controller to mobile phone, I always close any other apps and clear the system’s memory. But whenever I start p4d capture the app always ask for plugin installation. This is not happened in other mobile phone, the app runs normally.

There was an important release on July 1st. DJI changed the activation procedure to fly drones with third-party applications. Part of this major update relies on the new SDK (sets of programming tools for communicating with the drone), version 4.1, that was integrated by our developers in version 3.8.3 of Pix4Dcapture and version 1.6.1 of Ctrl+DJI.

Please use the latest versions and also the latest version of DJI GO.
Let us know how it goes.

Hi Julie,

Has this been resolved yet? We are running latest DJI Inspire1Pro firmware, latest versions of DJIGo, Pix4DCapture & Ctrl+DJI … on Samsung Galaxy S2 Android 7.0

We have tried every combination of online/offline/off/on of apps and sequences but cannot get the Pix4DCapture app to work.

We get the following SDK error when trying to test Pix4D Capture app 

 

Hi Erika,

You can find the latest news about this issue under this community thread:
(Android) DJI SDK failed to initialize […] void.dji.internal.f.b.b()

Ok, thank you.

hello Julie,

I have updated the apps but the result is the same. But in Zenfone max the apps run normally. So far the solution is I start ctrl dji first and now the drone connects easily. So I don’t start pix4d first because it still always ask for ctrl dji installation.

I hope for the next update the apps becomes more stable. Also it supports Phantom 4 Advanced.

cheers

Hi Hidayat,

Thank you very much for sharing your solution! Our developers are already working on upgrading Pix4Dcapture to SDK version 4.2. A new Android app should be released in few days (next week) and this SDK version is expected to be more stable.

We did not test the compatibility with DJI Phantom 4 Advanced at the moment. You can try to use DJI Phantom 4 Advanced by selecting Phantom 4 Pro in the app. If you wish to give it a try, feel free to report your feedback in a new community thread.

Hi Julie, i’ve updated the FW in my I2 and the respective apps to run capture (Android). Since the updates I have been unable to connect to the craft via the app to plan some new missions. I’m using the same tablet as before. All worked before the FW updates, was able to connect, plan and fly grids etc. DJI GO 4 is all ok but I’m getting no data into ctrl+ on it’s own. Need to get this sorted as have flights planned soon for mapping research. Thanks! Conor. 

@conor, answered here: 115010093426

I am successful with my first mission on my Inspire 2 with X5S as sensor. I fly at 175 on iOs version but since we will be working on a very large project. I will switch to android. These are my questions:

 

  1. Is Pix4D compatible with Galaxy Note Pro SM P-900, Android Version 5.0

  2. I already installed but haven’t tried p4d on the field. When I tried to have a flight plan at 200 which is still okay since we have x5s sensor, I noticed that there is a warning of altitude too high. Can I still fly even with that warning? Thanks.

3 On iOs version, when you set the altitude, there’s a GSD indicator below altitude but I cannot find it in android. It may be there but I still don’t know. I can compute for the resulting GSD before flying but as a help on projects with rolling terrain, a project area with 600m difference in elevation  it will be a big help.

Kindly help me. 

 Thanks.

Hi Roy,

Allow me to answer point-by-point:

1.) We did not test this specific device here in the office but we think you should be able to use it.

2.) Regarding the altitude, by default the limiting height on Android and iOS is 150 m for all drones (except Bebop 2), but this can be extended to 500 m if the Advanced mode is activated for flying. You will be able to fly the mission despite the warning. 

Note that we do not recommend to fly too high since connectivity issues might happen. Also make sure that it is legal to fly that high in your country.

3.) The GSD indicator is not available on the Android version at the moment. You can calculate using thistool

Best, 

Hi Blaž

With regards to #2. Altitude. Can I fly more that 500? Let’s say our client just want 40 cm GSD. Basically I would fly about 440m AGL already if I want 10 cm GSD. So I might need to fly higher than 500, Can we do that? Thanks. It is legal to fly more than 500 at the project area that we will cover. Thanks