Support Website Contact Support Blog

Pix4d stops working almost immediately

Running some initial processing in Discovery on my laptop, whilst I try and process in full Mapper on a PC

 

It was working last week - I upgraded, as requested, and now it crashes when I try and load a file. I can sometimes open a project from the front page (it crashes if I pick from an Explorer list), but not always.

 

Rolled back to previous version. Now does the same thing.

 

All very frustrating!

Dear Paul,

This issue has already been solved in a personal support request. To help other followers of the post facing the same issue, we will summarize our answer here: 

Based on the error message of the event viewer (Faulting module name: ntdll.dll), the crashes do not seem to be related to Pix4Dmapper; it seems to be related to a faulty hardware component, a driver or an issue of the operating system.

Since you have already run a hardware check and updated the drivers, this seems more related to the operating system. You can keep this in mind if you face this issue in the future.

Best regards,

I have the same problem, if I try to open an Explorer list, it crashes the program. I have had support to help me with the pc, but they don’t find anything wrong with it. This is the rapport:

Programnavn med feil: pix4dmapper.exe, versjon: 3.1.23.0, tidsangivelse: 0x58b3f3d4
Modulnavn med feil: ntdll.dll, versjon: 10.0.14393.479, tidsangivelse: 0x5825887f
Unntakskode: 0xc0000374
Feilforskyvning: 0x00000000000f8283
Feil prosess-ID: 0x17a8
Feil starttid for program: 0x01d29c0b47ab8b70
Feil programbane: C:\Program Files\Pix4Dmapper\pix4dmapper.exe
Feil modulbane: C:\WINDOWS\SYSTEM32tdll.dll
Rapport-ID: 8d1aad6d-89b1-42cb-9454-f5abf046c40c
Fullstendig navn på feilpakke:
Relativ program-ID for feilpakke:

Any suggestions?

Ole, is this after an upgrade of Pix4D?

Found this while looking for a solution!

File Explorer Interaction shuts down Pix4D Desktop on Dell Machines

Updated: March 06, 2017 15:40

Follow

Error

Pix4D Desktop, version 3.1 or later, is crashing when interacting with the File Explorer in Dell machines. 

 

Description

Pix4D Desktop is crashing during any interaction with the File Explorer. For example, when:

  • opening a project from the _Project _menu.
  • saving as the project.
  • importing a GCP file.
  • selecting the images when creating a project, etc.

 

Cause

The crash is caused by a library which is part of a software called Dell Backup and Recovery (or AlienRespawn, alternatively).There is a conflict between a later version of a library used in Pix4D Desktop and an earlier version used in Dell Backup and Recovery that is causing the crash.

 

Solution

Remove the Dell Backup and Recovery software (or AlienRespawn, alternatively) from the computer and try to create a project again.

 

It solved the problem!!

Ole, that’s really interesting.

 

My laptop (the machine that gave me issues) is a Dell. However, so is my desktop work PC, which is fine. Just looked, and it does not have the Backup and Recovery software on it. This seems to prove your point.

 

Unclear as to why Pix would update software so it no longer works - remember this only happened at upgrade time - but what can you do?

 

I’ll go to my laptop and delete - it isn’t as if I used the facility anyway.

 

Cheers!

hello there,

why this will be happen in my project

Hi Tom!

We would need more details to provide assistance in the most efficient way. Could you please send us the following?

▸ The quality report (.pdf format): …\project_name\1_initial\report\project_name_report.pdf
▸ The project log file (text file): …\project_name\project_name.log
▸ The project file (.p4d): …\project_name.p4d

Additionally, please send us the machine specs:

  1. Click the Windows Start icon and type System Information. Select the application in the list above.
  2. In the application, click File > Save… and export the content.
  3. Attach the file your_file.nfo to the reply.

Please upload the files to our OneDrive that I shared via email.
If you don’t see my message, please check the spam folder.

Thanks!