Support Website Contact Support Blog

Pix4D Desktop Crashing at Startup

Hi! I just signed up for the trial yesterday and so far Pix4D was working fine. I processed the Tutorial map and one of my own dataset without any issues. Today I added my same dataset with oblique photos and was processing at low resolution adn it was stuck at the DSM generation for a long time. So I cancelled it. Ever since that Pix4D refuses to start and throws an error message on startup saying it has crashed. I’m running WIndows 7 64-bit on a Samsung NP550 with an i7 and GT650m GPU with 8GB of RAM.

So I tried the following:

  1. Uninstall Pix4D 4.0.21, restart my system and reinstall Pix4D 4.0.21. It still wouldn’t start.

  2. Uninstall Pix4D 4.0.21, restart my system, install newest nVidia drivers 385.69 for my GeForce GT650M, restart system, reinstall Pix4D 4.0.21. It was still crashing on startup.

  3. Uninstall Pix4D 4.0.21, restart my system, install Pix4D 4.1.3 Preview. Now the License agreement popped up but it still crashed. It gave the following error:

 Problem signature:
Problem Event Name: APPCRASH
Application Name: pix4dmapper.exe
Application Version: 4.1.3.0
Application Timestamp: 59ce31e8
Fault Module Name: KERNELBASE.dll
Fault Module Version: 6.1.7601.23418
Fault Module Timestamp: 5708a89c
Exception Code: e06d7363
Exception Offset: 000000000001a06d
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional Information 1: 0f2a
Additional Information 2: 0f2aa0a7495842690a9a5a2faaf733ca
Additional Information 3: a8b9
Additional Information 4: a8b93ed8a6775a12d4cfffbd28f352f4

 

You should contact support so you can send them the log files.  It is very unusual for reinstalling to not fix this problem and the support people can help better then the community people.

@Arunabha Bhattacharya: Thanks for submitting a ticket, we got back to you by email. We’ll post an update here if the case gets solved. :slight_smile:

Same issue here. Working one day, crashes on startup the next. No changes to the PC as far as OS or patches. Crashed at the end of a project and has crashed immediately on start-up ever since. 

 

Same as above, uninstalled, removed …/users/%uid/appdata/local/pix4d directory, no files or folders left under program files. Reinstalled and crashes immediately. Updated video driver just in case, no difference. 

i7 4-quad core, 128gb ram, nvidia gtx1080, win 7 64bit (sp1)…

It has something to do with the way you (Pix4D) changed your login process. I noticed the login is now changed and allows some to use Discovery, some to extend a trial and some to choose a PRO License. If I login with a new user account (windows) the app opens and asks for a pix4d logon to use. 

 

If you can provide where in the registry (profile) you are storing the login information pix4d uses at start up (last logged in Pix4d user) my guess is we would be able to delete that entry and the app crashing would stop.

I had the exactly same problem when I renewed my license. Uninstalling the 4.0.24 version, installing older 3.3.29 version then uninstalling it, and finally installing the newest version 4.0.24 again solved the problem. I think this has something to do with the login process.

Thanks guys for looking into it.

I’d like to give some more information to the developers so that they can fix it. For those that were not able to solve the issue yet, could you please share the following file by commenting with a link of the file in a sharing service (e.g. Dropbox, Google Drive,…)? 

1.Click the start button.
2. Type Run.
3. Press  Enter.
4. and type regedit.

  1. and press  Enter.
    6. In the Regedit app, expand the tree on the left by double-clicking on 
    Computer\HKEY_CURRENT_USER\Software\pix4d.
    7. Right click on Pix4D and select Export.

  1. Send us this .reg file

That should help our developers! Thanks!

I had this problem once the trial expired, but it is worse than that.

I have been evaluating dronedeploy and Pix4D. Since my internet is veeeeery slow (1Mbps shared between 3 households) I liked the ability of Pix4D to process the maps at home.

I managed to process 1 map with Pix4D and the result was good, very similar to dronedeploy, but the android app on Pix4D is much better, but as soon as the trial expired, Pix4D started crashing on stratup. Not only that, but now chrome can’t load any dronedeploy 3D maps claiming compatibility issues.

I’ve no idea why this is, but there is a clear difference between the day the trial was to expire and the day after it expired. Both stopped working the day after the trial expired.

I’ve tried a few workarounds, including updating geforce drivers and uninstalling Pix4D, changing some flags on chrome, but still I can’t see dronedeploy 3D maps on this PC, but I can see them on my old laptop where I never installed Pix4D.

Hey Michael, 

As soon as your trial expired, while logged in with the Discovery license, the software was crashing, is that correct? 

  • Which version of Pix4D software do you have installed?
  • When exactly is the software crashing? Is it right after the splash screen appears?
  • Can you describe the steps you are following? 
  • Is there a repetitive pattern? Can you reproduce the crashes? 

You mentioned that the internet connection is very slow. Have you managed to verify your username and password? 

Looking forward to hearing from you.