Support Website Contact Support Blog

Pix4d mapper for Mac

I installed the app on my Mac with maxOS Sierra with no problems but when I try to login I see this.  I searched existing support posts and found one that said I should try installing the root/intermediate certificates.  I did that and it didn’t make any difference.

Me too…same on both of my machines (MacBook Pro and iMac).  I have been running Pix4D since December with no issue.  Today my laptop would start the application for less than 2 seconds before it would terminate with no error message.  I could just briefly see the main screen before it quit.  I get the same thing from my iMac.  I tried to reinstall on my laptop but now I get the screen message you show above.  

This has to be a Pix4D server problem.  I have put in a support ticket on it but no response yet.

Looks familiar.  I had this yesterday, (MacBook Air with OS-X Sierra, Pix4D 3.0.13), reinstalled 4 times (tried both versions 2.2.25 and 3.0.13) and always the same.  Hope it is solved soonest.  

Just got an update on my ticket… Pix4D server side certificate issue.  They are trying to solve it with an update to the software itself - new version.  Should be coming within a few days, maybe as early as tomorrow.  Use the Windows version in the interim if you are stuck on the login screen, no other option right now.

Hello All,

There is an issue in version OS X 3.0.13 related to the certificate of communicating with the server which expired on Sunday.

For the Windows version, the issue has been addressed and upgrading solves the issue. You can find more information here.
For the Mac version, we are working on releasing a bug fix 3.0 version that will solve the issue in the following days.

As a workaround, for the moment, you can:

  1. Install bootcamp and use the latest version of Pix4Dmapper. You can find more information here: https://support.apple.com/boot-camp
  2. Create and process a project in Pix4D Cloud and download the outputs: https://cloud.pix4d.com/.

Please make sure you follow this forum postto be notified when the bug fix version is released. 

We sincerely apologize for the inconvenience caused and we hope to provide you a permanent solution very soon.

Best regards,

Good Morning,

 

I was wondering if you tell me if there is an update of Mapper Pro coming soon for Mac version with some key features added to it as with the windows Version 3.3.17

Hi Alan,

Please find the latest news under the main post dedicated to Mac computers:
https://community.pix4d.com/t/5672

Hello, 

I am trying to download pix4d for mac and can’t find it anywhere.  Where should I go?

 

@Michael: to this post: https://community.pix4d.com/t/5672–Beta-OS-X-version-of-Pix4Dmapper-3-0

Hi,

 

I have just tried to use the Pix4d program and it is telling me that there is a new version of it, I run a mac and the new version is not available on the suggested link, I have also followed the link that is listed right above and download that and installed it and no change.  I am starting to find that Pix4D is having way too many problems for the cost of the program, you don’t even have the link for the program for mac users on the standard software download page.  I use this program for a business and I am very quickly losing my patiences in using this program.  As there is little to no support for ISO users and now with another issues with the program I am starting to look for other programs that offer better service.

Hi Joseph,

To clarify the situation, we changed our licensing system and now make mandatory the use of the latest version for trial users. However, as the macOS version is 3.0.18 (development still on-hold at the moment) while the latest version is currently 4.0.21, it is not possible to use a trial. I contacted you via email to provide a workaround so that you can use Pix4D Desktop.

Sincere apologies for the inconvenience.

Main thread about macOS version, please comment under this post: https://community.pix4d.com/t/5672