Support Website Contact Support Blog

Pix4d Mapper Crashing

Hello,

I am new to Pix4d and I am looking for some help. After my initial download and installation of Pix4d mapper, I am having difficulty getting any project to open. If I try to open a file through file explorer, it always crashes after displaying the pix4d splash screen that shows the version number on it. If I go into pix4d mapper and select open project, it will attempt to open a project, but when it gets to 96-99%, I get the not responding message that seemingly won’t go away. How do I get past this issue? I have spent almost all of my trial trying to get it to work. I found a thread stating there was a previous issue with dell backup software and pixc4d, is that still the case?

Dell G7, 32GB RAM, NVIDIA RTX 2060, i7-9750H

Hi Jerry. I replied to you via the ticketing system. Did you get my response?

Sorry, been out of the office. Check tomorrow.

Hey Jerry:

I was having the same issue on both my WIN10 desktop and laptop. For me the problem extended to any software which was demanded a heavy processing and/or memory load. It was tremendously frustrating and I couldn’t find answers anywhere, that despite my black belt in Google-Fu!

Then, one glorious day, I found a post on some help-desk forum board, somewhere I can’t remember. A post which offered a suggestion which I had never seen before. It took approximately 3 1/8 minutes to complete for each computer, something that made me instantly dubious it would do anything. That was 2 months ago, and both computers are operating at speeds not seen before, and notta one program has crashed on either.

I never found an explanation regarding why this was somehow adjusted, because I can guarantee I had never been to this particular settings page before on any computer. Somehow, on both machines, the allocated virtual memory was set so low that an Apple IIe would have crashed! If you are unfamiliar with how to check for this issue, you’re in luck. Here’s the steps:

  1. Click the “Windows” Button in the lower left corner of your desktop
  2. Select the system settings gear
  3. Select the “System” Icon
  4. Scroll the left panel menu down to the bottom and select “About” icon
  5. In the upper right hand corner under the Related Settings header, locate and select the text “System Info”
  6. On the left side of the window which pops up, at the bottom, select the text “Advanced System Settings”
  7. In the small pop-up window, select the “Advanced” tab
  8. In the top section labeled “Performance”, select the “Settings” button
  9. In the small pop-up window, select the “Advanced” tab
  10. In the section labeled “Virtual memory”, select the “Change” button

In the final pop-up, you will be able to determine how much virtual memory your system is able to access. There are three options for virtual memory, “Custom”, “System Managed”, and “No Paging”. I found my first computer with “Custom” selected, however the minimum, or initial size box was empty, and the maximum size was a meager 2400 MB. I found the second one set to “System Managed” however the amount of memory indicated below was roughly 2700 MB.

I decided to take the advice of this forum post and set both computers to “Custom”. In the initial size, I entered “3000”, and in the maximum I entered “30000”. I did this based on both indicating there was over 64000MB space available.

I don’t know why they were set like that, I don’t know if the sizes I entered into the initial and maximum boxes would be considered inefficient or if Microsoft would recommend I do something else. I do know, however, that ever since I did that, I’ve never been happier with either machine.

If you try this, I truly hope you see the same results. Stupid computers being stupid is why these things get punted into the streets. Good Luck!

Not sure exactly. Let me check. Is it possible to extend my trial any to continue to work through issues? Like to figure out if it is file size or something else going on? I’ve been out of the office a ton lately and haven’t had time to mess with it.

Tacked on another 12 days. Hope that helps.