Phantom 4 Disconnected during Mission - Unable to analyze the Log

Hi there,
Yesterday I manually created a Polygon Grid Project of 6.43 Ha prior to fly, using a Kmz file and 2 Polygon Missions (one with N-S shoots, and one with E-W shoots); when I reached the site, I first run a flight with DJI Go 4 in order to check functionalities and obstacles, and it worked fine. Then, I killed the manufacturer’s app, and I launched CTRL+DJI, followed by Pix4Dcapture, in both cases giving Permissions to every notification; the first Mission was fine, however I had troubles during the Second one: at a certain point (12:02) I started to receive a new unespected series of “CTRL+DJI Permissions” request on my Android phone, whose ones I accepted; meanwhile, I noticed that I lost radio contact (the signal logo showing a green wave movent, N/A in battery logo, no video stream), while the drone was still following the mission path.

I first turned off and on the controller, but it didn’t work; then, I closed Pix4Dcapture and CTRL+DJI, re-opening them in the opposite order, and it still not worked, while the drone was doing its work. Finally, I did the Shut Down sequence Shut down controller - Exit Pix4dcapture - Exit CTRL+DJI - Open random app to habilitate the “clear cache/background”- Close this app, followed by the Sequence Open CTRL+DJI - Open Pix4Dcapture - Turn on Controller. It worked, and I started again to receive datas from the drone, just in time to see it performing the last shootings and make the correct Auto-land.

However, I lost the Mission 2: all the jpeg images of the day were all together in the DCIM folder as usual, but the specific Mission 2\data folder was empty.

Because I’m unable to analyze the attached log and dataflash (I can just confirm the time of the failure, thanks to the “UNKOWN” word spreading from 12:02), I would appreciate your help in order to solve this two questions:

a) What happened exactly, in order to avoid the same event?
b) What is your best practice when you loose communication with the drone during a planned flight, if the drone is apparently following the path and so it is not showing an hazardous behavior?

Besides English, accetto risposte in Italiano, así como en Español et Français (mais je ne suis pas capable de répondre en cette langue)

dataflash.log (806.9 KB)
Mission 2.log (1.2 MB)