Support Website Contact Support Blog

Orthofacade Occlusion (Black Areas in Output)

I’m working on a detailed building scan, outputting orthofacade’s of each section of building exterior for inspection.

The process has been working quite well, until I ran into issues with some of the orthofacade’s outputting mostly black nothing, instead of the crisp outputs from the rest of the building. I’ve run a series of tests and determined that this is due to the shape of the building and the way that Pix4DMapper is handling the orthofacade generation. The section of the building I’m running into issues with is a “Y” shape, like so:

The first orthofacade worked great:

The second did not:

After adding in several more MTPs and re-processing to ensure I had a great densified pointcloud, I finally realized that the actual problem was that the south side of the building was “blocking” the orthoplane. Even thought the orthoplane clipping box does not intersect the the south side, the program seems to be projecting from much further back, resulting in occlusion from the south part of the building.

I confirmed that occlusion was the cause by angling the orthoplan for that section of the building to verify that it wasn’t the pointcloud that was the issue:

I’m wondering what the best option is to output a proper orthofacade of these areas of the building that are occluded by other sections?

For anyone else encountering this issue, the fix is to assign the offending portions of the point cloud to “Unassigned” which removed them from the orthofacade processing. Doing that removes the occlusion.

Hi Larry,

Thanks for sharing your issues and workaround that you have experienced with our software.

I would like to mention that sometimes the generation of an orthoplan is not so straight forward to reconstruct especially as the mosaic editor is not available for this output.
Some users tricked the software in order to have their orthoplan horizontal so the software considers it as a map and then they were able to use the mosaic editor.

I would like to add that for orthoplan, our algorithm is not optimal and has some difficulties to reconstruct orthoplan if you are using both orthogonal and oblique images.
Therefore in order to get a proper orthofacade, I recommend you to process step 1 and 2 and then select only the cameras that are facing your orthofacade and disabled the other ones in the images properties window. As shown below:


Once you have enabled only cameras that are facing the orthoplan, you can generate it.

Hope this will help to improve your results.

Best

Thanks for the tips, Holden! Those pieces of advice will be very useful for our future capture and processing.