Support Website Contact Support Blog

No video feed after app update on Phantom 4

Hi we updated our apps lat night and we have now…

No live video feedback
All drone speeds have slowed down

This is on two separate P4s one a pro and one an advanced flying today both from IOS updates

Thoughts and help appreciated as we reply on the feedback for close proximity flying and also check the pause in the image to check a photo is being taken

help appreciated

Michael

@Michael_May same issue here used it on Tuesday and worked normal. I use a Phantom 4 Pro V2.0 on IPAD. Tried using it Today in the field on a job had the same issues. Also the drone on the screen does not move when the actual drone starts to move to mission as well as some other glitchy things happened that’s hard to explain. Does anyone know if there is a way to install the older version?

This was the unhelpful reply failing to acknowledge at all this has been reported by at least three individuals !!

Hi Michael,

Sorry to hear that. We do not offer personal support for the free Pix4Dcapture. We are here to answer your questions about Pix4Dmapper and other paid products. However, you can post any of your inquiries on our community page. We are closely monitoring it and you can find the answer to your question through our community. You can also connect with other users on the Community, and ask for advice from your peers.

The behavior you are describing can’t be replicated on our side and has not been reported to us so far. I would suggest you go through all the basic checks and troubleshooting steps as it will solve most of the issues that can be encountered if properly followed.

Regarding the drone speed, there has been some changes. The app computes the maximum speed the drone can have for a given overlap and flight altitude. The Fast speed corresponds to 100% of the maximum speed. Reducing the speed might help to avoid capturing blurry images. Five types of speed can be selected:

  • Slow : 0.1 m/s
  • Slow+ : 70% of the maximum speed.
  • Normal : 80% of the maximum speed.
  • Normal+ : 90% of the maximum speed.
  • Fast : Maximum speed.

And my reply!!!

It has been reported to you and you have replied !! It has been tweeted your app has bugs and doesn’t work please as a lifetime license holder sort it out or communicate to those who can !!

Simple customer service

Same issue with no live image on a mavic pro. I thought it was the iOS14 update, but apparently not.

Hi Everyone,

The live video feed for the Phantom 4 Pro drone should work. This issue hasn’t been reported since April 23 after the release of the newest version. I would definitely suggest you to check your camera settings. I would also suggest you go through all the basic checks and troubleshooting steps as it will solve most of the issues that can be encountered if properly followed. You can also reinstall the software to see if that helps to solve the issue.

However, for the Mavic Pro drone, the video live feed might not be working as it has been reported by multiple users.

Regards,
Kapil

Hi well I have reported it
James Wilthew has reported it and both on phantom4s after updating yesterday

It doesn’t work

Michael May

+44 (0)7730 382188

Same trouble here
Using the Phantom 4 Pro
No camera
The drone goes very slow
Trouble with changing the size of the grid
Etc…

Hi @Michael_May, @tmcguire,
Thank you for reporting the issue, we were able to replicate the issue on our side. We will work on fixing it.

@post3, As I said, that the minimum speed of the drone is changed but the maximum speed should be the same. However, we want to investigate the issue, can you forward me the log file of the flight. To do so, follow the steps explained in the below support article, (Android, iOS) How to extract the log files.

Will do, what is the email you would like them to be sent to? I only have logs for one small test flight because I deleted the app then downloaded again while troubleshooting the issue.

Thanks,

Tim

image003.jpg

Hi @tmcguire,
Can you upload the log files in the link below? You can also include as much as information you can so that it would be helpful for us. You can extract the log files by connecting your device to the iTunes >> app> Pix4Dcapture >> mission.

Hello Kapil,

I tried uploading them both ways just now on the drive and sending them by email hopefully you got one of them.

In regards to the flight yes the speed was way out of wack and I know you guys did just adjust the speeds but it didn’t seem right. I had to put it all the way to the top fast to get my drone mission down to the same time as when I used to fly it in the Normal speed. My main concern was two things. One the camera was very weird I attached a screen shot of my IPad what it looked like. Second when I was making moving my map bigger or smaller the flight path wouldn’t adjust in size with the zoom level of the background map. All in all it was very strange and I have not had these issues with the older version.

Hope that’s some sort of help, let me know if there’s anyway I can download the older version.

Thanks,

Tim

IMG_0213.png

Thank you.

Please help!

I’ve been having the same issue on my P4 with the IOS version.
No video feed and the map has issues when trying to adjust the size or position.
Also, when you launch a mission, you cannot see where the aircraft goes on the map as well as see where it takes pictures.

I have tried on 4 different devices (all IOS) and the issue is still there.

Thank you,

Mathieu

Hi,

At the moment no Video feed on (only for a few days):
Phantom 4 Pro
Phantom 4 Pro Obsidian
Phantom 4 Pro V2.0
With 3 different ipads, IOS 13.7 and IOS 14

Thanks,

Mariola

Hi All,

Thank you for reporting it to us. At the moment we are aware of the issue with the live video feed for Phantom 4 Pro drones, We are working on it and will be fixed on the next release.

Thanks,
Kapil

Hi Kapil. Thank you for your answer.
Do you have an idea when the next release will be?
Because at the moment the app is not usable with these bugs.
Thank you!

Is there not an option to re release the previous version of the app in the meantime?

Michael

1 Like

I don’t have location, live video and my location keeps jumping around. Can you rollback to an older version?

1 Like

I’ve been flying with this for 2 years without any real issues with my P4P. I bought a brand new P4P v2 and having issues with the app. Not getting a live view, drone position or camera indicator when a photo is taken. Drone info appears correct in the HUD(battery, sats, distance, etc)

Is this a P4P v2 issue or a ios14/app issue?! Please help, nervous to fly these jobs without it working 100%.