Support Website Contact Support Blog

Pix4D Capture on Android - Flight Speed Issue (on Phantom 4 Pro)

Hi everyone,

I have a Phantom 4 Pro drone and I use a Samsung Galaxy Tab S 8.4 (running Android).

I’ve been using Pix4D Capture for a while now and I have never experienced any problems. However, on my last flight I had an issue with the flight speed. The drone flew all the mission in a very very very slow speed. As a consecuence, I had to abort the mission because the battery wasn’t going to be enough.

Any ideas of what is happening? I’ve tried the same mission a few times again and I keep having the same flight speed problem.

Thank you in advance,

Romina

Hi Romina,

Could you please confirm:

  • The latest versions of both Pix4Dcapture and Ctrl+DJI are installed.
  • Latest firmware is installed on the drone and the remote controller.
  • The latest DJI GO (4) version is installed.

Also, was the drone recently calibrated with the DJI app?

Hi Julie,

Thank you for your answer and sorry for the delay (some internet issues here).

When I made that flight I had the latest versions of Pix4D Capture and Ctrl+DJI. Also I had the latest firmware installed on the drone and the latest DJI GO 4 app.

Tomorrow I wil flight a new mission with Pix4D with the latest versions of all apps and drone firmware. I hope I have no problems. I’ll report later how it go concerning this matter.

 

Hi Julie.

Finally I flew four different missions and the speed issue seems to be solved.

Thank you for your time.

 

Great to hear that it worked!