Support Website Contact Support Blog

No download option

Hi there

So Im using android with a parrot bebop 2.
I complete the mission… Clicks being made to confirm pics being taken. SD card memory going down as it plays out…
Can’t download the pics after…
When I go onto. Parrot freeflight all the pics from the mission are there… However pix4d doesn’t register any data…

Please advise… This is driving me crazy. I’ve tried everything to get it working

Hi Ben,

If my understanding is correct, you are flying the Bebop 2 using Pix4Dcapture, everything is going fine but then you can not download/transfer the images to the mobile device, even though the images were properly acquired on the drone SD card?

I would have a few questions more about the behavior you encountered:

  • Are you using the Android or iOS version of Pix4Dcapture?
  • Are you using the SkyController 2?
  • Is the option to automatically synchronize the images on the mobile device activated in the Settings?
  • Is it not working for all the missions you are doing or it is random and happen from time to time?
  • Can you provide a relevant screenshot of the issue or state what error message is displayed?
  • Did you give all the necessary permissions to the Pix4Dcapture application when installing it on your mobile device?

It can happen from time to time that the download from the drone to the mobile device is failing. Make sure to be connected to the drone with Pix4Dcapture when downloading the images.

Best,

Hi and thanks for the reply

So basically the drone bebop 2 performs the mission… During the mission the pics are taken and the SD memory starts to decrease… Once the mission has finished there is no option to download photos… They aren’t stored anywhere…
The only way to retrieve them is to manually go back and open freeflight pro and take them off of there… Then upload to the cloud…
I am using android.
Parrot bebop 2
Sky controller 2

All necessary permissions allowed…
I have literally tried everything will no avail…
Am I missing something?

Hi Ben,

I am still not very clear with your issue.

  • The automatic synchronization is not working?
  • What is happening when entering the project and tapping on _Download image_s.
  • Images are well stored on the drone SD card, right?
  • Have you been able to synchronize your images from the drone to the mobile device in the past?

Looking at the manual on our support website, it is button 2. Did you try to download images using it?

Best,

Hi there…

So when I click on the project it has a download button but not highlighted… I can’t click on it to download any images…
The images are on the drone and I have to use another application to remove them…
Have you got an email I can send you a screenshot?

Hi Ben,

When you try this operation, are you properly connected to the drone?

If possible:

  • Try another USB cable. It might be a potential cause.
  • Reinstall the drone manufacturer application

I would suggest you to go through a full reinstall of the app from scratch.

Caution

The two procedures below may imply data loss so we recommend to make a backup if there are important data saved. Connect the mobile device and copy the Pix4D folder (Local Storage > Device storage > Pix4D) to your computer.

1. Clear data and clear cache memory of the application

  1. Open the Settings application on the Android device.
  2. Scroll the list and tap Apps, Applications or Manage apps.
  3. (optional) On certain devices like Samsung, tap Application Manager.
  4. Scroll the list to find the application.
  5. From the list, tap Storage.
  6. Tap CLEAR DATA and CLEAR CACHE.

2. Re-install Ctrl+Plugin and Pix4Dcapture from scratch

  1. Uninstall Pix4Dcapture and Ctrl+Plugin.
  2. Connect the device to a computer and navigate to Local Storage > Device storage > Pix4D.
  3. Delete the content of all folders.
  4. Delete the Pix4D folder.
  5. Re-install the latest version of Pix4Dcapture and Ctrl+Plugin.
  6. (optional) Place the backup content back into the Pix4D folder to restore data.

Best,