Support Website Contact Support Blog

No camera view on iPad Mavic 2 Pro

Hi.

I have the same issue with iPad mini and Mavic 2. I wonder whether I could be fixed.

I’ve got the same problem both on Androïd and iPad Mini. It happens that sometime, it does work.
After waiting a few seconds, or unplug-plug, or action on the video recording button of the remote, or just luck at first time, but in general, it just doesn’t work at all.
I subscribe to this post to follow and I hope to get good news someday…

Hi all. Came here to get a solution to the same problem and I got it here.
(using Mavic 2 Pro with and iPad)

For me it does seem that they issue of having DJI GO4 app open before opeing Pix4D Capture was the problem.

When I opened Pix4D Capture up first I did get the camera feed to the app. If I have DJI GO4 open first I’d get the black screen in Pix4D Capture.

The issue for me is that running DJI GO4 first to completed pre-flight safety checks as part of our process mean that I need to go there first. The tip of unplugging and then re-plugging the cable to my iPad works.

So my workaround is to start my Mavic 2 Pro. Then open the DJI GO4 app and do my pre-flight safety procedures. Next close out the app, unplug the cable to my iPad/re-plug it in, and start Pix4d Capture app. Al works as expected after that.

In thinking of it, it does make sense. The camera can only send a signal to one app. I guess what ever app last had the feed has a lock on it and only disconnecting the cable breaks the lock. Though reverse did not seam to matter. i.e. I open Pix4D Capture first, check the camera feed, get out of the app and open DJI GO4 I get a camera feed even without unplugging the cable.

Anyway, least for me these steps seem to work and solve the issue.

JT

Thanks Duane, I’ll try that routine later today myself! Sure would be nice to get back to normal.

Hello
Since one week I can’t see images on my screen, working with an iPad and Mavic 2 pro.
it’s not a drone’s problem , since I receive an images when I switch to GSP.
This issue was always present but I use to shut down the. drone radio and then the live images appear . Now shutting down the radio doesn’t help.
Also some times the drone stability is very bad only. when I’m working with Pix4D, very disappointed.

Hello everyone,

You should be able to have a camera view while running the iOS version of Pix4Dcapture. We can’t replicate the issue on our side. If you have any issue, I would suggest you to go through our basic checks and troubleshooting steps as it will solve most of the issues that can be encountered by users.

Still having the same issue with the Mavic 2 Pro on an iPad Mini5 with Pix4D version 4.10. Also does not work on iPhone X with same version number. Have tried all suggestions in regards to force quitting DJI app, unplugging and plugging back in, turning off and on controller, never opening DJI app, deleting and reinstalling Pix4D. Nothing works. Still just a black screen for camera view. Missions fly just fine, but no live view. And there is nothing helpful in the basic troubleshooting steps in regards to this problem.

Kapil,
How can you and Pix continue to take that nonsense stance of “we cant replicate on out end” when user after user comes to this thread, reporting the exact same issues!?!? Its maddening and is forcing most of to look for alternative platforms.

If I take the exact same iPad and cable and connect to my Mavic 1, it works, when it doesn’t work on my Mavic 2. Clearly the issue is on Pix’s end, so fix it.

Hello @Jason_Zier,

We did the testing today and we were able to retrieve the Mavic 2 Pro video feed with the recent version of Pix4Dcapture on iOS. So, the issue shouldn’t be related to the app, I would always suggest trying the below methods to see if that is helpful.

  1. Unplug - replug cable from RC to device
  2. Kill Pix4Dcapture and re-open
  3. Switch everything off and on

Regards,

I did the testing this weekend as well. Multiple flights in different locations. Tried turning everything off and on. Tried unplugging and plugging back in. Tried opening DJI, force quitting and opening Pix4d. Tried never opening DJI and only opening Pix4D. Tried quitting Pix4D and reopening. Could not get it to work on a single one of my flights. Even tried contacting customer support, who promptly told me that since I don’t PAY for Pix4D that they would not help me.

I have the same problem. Nothing works from this thread work.

  • Black camera view
  • iPhone 6s latest iOS
  • latest app version from the app store

I am a programmer I can debug it for you, just let me know how :wink:

Same issue with my new Mavic 2Pro and iPhone. No video feed whatever I try. Works fine with my cousin’s Mavic Pro.

Skydio is coming out with “Scan 3D” soon.

Between Pix4D’s lack of support on this issue and the fact that there have been absolutely no improvements to the Capture App combined with DJI’s atrocious customer service, I’m looking forward to moving on from both of these vendors

After the list firmware update of Mavic2pro, pix4d mapper does not see the camera (during the flight) and does not capture images as programmed. I temporarily solved the problem by creating the flight plan with pix4d capture but shooting manually with DJIGo. There is no update for the IPad Pro (yet). Any ideas?

I tested it already on:

  • iphone 6s
  • iphone 11 pro
  • ipad mini 5gen

Nothing works, as somebody mentioned it is probably problem with controller or drone itself.

I can help you debug issue, just let me know here!
I am professional programmer :slight_smile:

Hi @stiffler.to,

The issue is not probably related to the phone. It should be related to the drone itself. This behavior is random so it is difficult to find the actual cause of it. If you want to do the testing, I would suggest you try it on the multiple DJI Mavic 2 Pro drones. We tried to it on our side and the issue was not replicated.

Regards,

So, what is being done to resolve the issue on the drones that don’t work? I honestly could care less if it works on your end; as the paying customer of Pix4d, I only care about it NOT working on mine. I also only have one Mavic, so testing on others isn’t an option. Quite frankly as the vendor, it’s Pix4d’s responsibility to trouble shoot and fix the glitch, not the paying customers. There’s plenty of users reporting the same exact issue. FIX IT!!!

I had a similar experience with MAPPILOT before.
That software vendor ordered me to start up and restart the controller, the aircraft, and the iPad, plug and unplug it, but that didn’t work. I did the same thing over and over again after that, to no avail, however they launched an investigation into it. It was worth the wait and the MAPPILOT’s video feed is now shown correctly with M2P. They fixed it.BTW,my PIX4D Capture’s video feed is still black…

I’d be more than happy to swap Mavic 2 Pro’s with Pix4D since it cannot be replicated on your end. I have one that has yet to work correctly. Seems like a simple way for us to determine the differences in hardware. It has to be something on the hardware side of things, be it different FW or different components being used in the uav/controller.

Anyone with problems close to San Fran?

Jason,
Nothing is being done. That’s basically how this conversation has been going. They like to point out that they don’t see an issue so everything should be good. We CONSTANTLY tell them that we still have issues and they continue to say “no it’s good” or try these steps, which are the same steps that we have already pointed out are not working for us. And “paying customer”? haha. I reached out to Pix4D customer service about this issue before coming here. Since Capture is a free program, they absolutely refuse to help you through customer service. Instead they direct you here which, as we have seen, gets us no where. Never mind that many people pay to use their other apps, and Capture is how we collect data for those services. We don’t pay for Capture, so they basically don’t seem to care.

As Thomas pointed out, the best bet would be to contact some of the people with the problems so they could troubleshoot with a drone that is having problems. There are several of us to choose from who I am sure would be more than willing to assist in fixing this issue. Anything beats more of the same “try these steps that you have already said don’t work” replies.