Support Website Contact Support Blog


Hi, i just bought a RTX 3070 card and my GPU doesn’t get above 2% or sometimes it will spike to 30% but thats it. I have tried the latest driver and the one before it with no luck. The card works great at games but i bought it hoping that the rendering would be faster using this GPU. The AMD 3700x works great and most of the time will be pegged at 100% doing steps one and two.Step three i get a little bit more out of the GPU but not as much as i would like. How can i take better advantage of this great GPU card? i have gone to the Nvidia control panel and played with those settings but no luck.


Pix4D does not utilize the GPU during processing very much. See this article from Puget Computers discussing Pix4D GPUs.

1 Like

Also windows task manager default view doesn’t show CUDA usage. You need to change one of the engine views to see that. There are also some GPU workloads that don’t show up in task manager at all.

Hi Carl. Mapper can only take advantage of the GPU on step 1 so any usage would only show up there. Currently, there is no setting to lower or increase the processing performed on GPU. For mapper the most important component overall for speed of processing is the CPU. See the Puget info for more detail.