Support Website Contact Support Blog

More missing file errors

So this time I have completed processing and gotten some output.  In the log I get the following message

[Error]: Error e9036: GDAL error <4> `F:/phantommissions/dangarsleigh3/mission_00009_0001/2_densification/project_data/mission_00009_0001_texture.jpg’ does not exist in the file system,

[Error]: and is not recognized as a supported dataset name.

[Error]:

 

Anyone have any idea what this is about?

Cheers
:slight_smile:

Hello Roger, 

Were you able to load all the results properly in the different view (rayCloud, Mosaic Editor…)?

Do you notice anything wrong when the processing of all steps is 100% completed?

Actually this error code is more a warning for the developers. It is not an indicator of good or bad processing.
It is something that should be hidden or more like a warning.

At the moment it is kind of misleading for the users. This error message should be investigated if you experienced a crash. 

If so, please send us a request with details about your project, together with the log file that you can find here:
…\Project_name\Project_name.txt

Best Regards,

Thanks for the feedback…no crash…a few cameras didn’t calibrate correctly but generally processing worked.  3d models weren’t as good as I liked but I definately think that is a result of my flying/mission planning.   I’ll ignore the file error warnings for now then.

:slight_smile:

 

Exact same thing happening to me too, after installing latest update

 

Same error, and mesh texture not recognised (despite being recognised before migration to latest version of Pix4D)

 

I’ve reprocessed out simple mesh & same error coming up, not bringing out the texture on the mesh at all

 

I’m working on a 4km corridor with no texture. I notice a lot of people getting this message and reporting it recently

Same issue, all data works though mosaic editing is very slow. Step 2 was green for a few days, now reverted back to red after a save as in both files. 

Now is failing to load image when zooming into the mosaic. 

Zachary, I think there are a lot of bugs in the latest release

 

What I have found is if you change processing options (and option turns red as you pointed out), the errors will appear when trying to edit, view etc

Changing the processing options to the original settings that you proccessed (turning option green) will eliminate errors 

 

I found a round about way of making the texture work after the [Error]: Error e9036: GDAL error <4>, thankfully I didnt have to reprocess out a HQ 4km mesh again. This involved moving texture file from 3d_mesh folder to the project_data folder and adding the suffix ‘1_1’

 

I hope pix4D can get to the bottom of this in the new release, as these bugs have just appeared. 

I migrated a number of projects to the new version to experiment and they all gave up errors depite having no errors in previous releases

Brian

Hello Cathal, hello Zachary, 

 

We are sorry to hear that there are some issues. Please make sure you have the latest version installed that can be found here:
https://cloud.pix4d.com/download/

We noticed that our colleagues are in direct contact with you regarding the errors you are mentioning. 

 

Best Regards, 

Hi,

I have just loaded the latest version and can no longer view a textured mesh. It only appears as black as shown here. Is there a fix to this? I have tried to revert back to the older Pix4D version but the textured mesh still no longer appears.

Is there a fix to this?

Regards,

Loren

 

Hi again, i have downloaded and processed the DJI_demo dataset and still the mesh does not appear as textureed? any help greatly appreciated !

Loren

Hello Loren,

The issue you are reporting looks like a GPU problem. 

  1. Make sure you have the latest graphic card’s drivers installed. Ensure that the graphic card supports  OpenGL 3.2

  2. Are you using two GPUs for instance?   

Please also check the system requirements here:
https://support.pix4d.com/hc/en-us/articles/202557289.  

 

Best Regards, 

I am facing the same problem,

 

  1. Gdal error 

  2. zooming orthodontic image file with transferred data to another pic … rest all working fine but when zooming orthomosaic it is showing error of missing files transparency etc. 

  3. errors in creating clusters , failed to create cluster … and later holes in project because of this error.

 

Need to solve these 3 different errors soon … thanks 

Hello @Sanket

Could you please submit a request to Support here and send us the following to further investigate: 

-log file (.txt file can be found in the results folder)
-Quality report ( .pdf file can be found in this path: project_name\1_initial\report)
-Step at which the error occurred
-Version of Pix4Dmapper downloaded
-PC configuration
 

Best Regards, 

Hi - problem fixed! I updated graphics card drivers. Thanks for advice.

 

Zachary Balge January 18, 2017 04:13

Now is failing to load image when zooming into the mosaic. 

 

I am facing same problem, When i move project from one computer to another. I tried everything - i check disk size type same disk - ssd to ssd etc number of files - save as project - still not solved.

.


Orthomosaic image

ticket number - (#32740)

Thank you

Hi Sanket,

We would suggest the following:

  1. Close the project having this message error in the Mosaic Editor.
  2. Access the directory: …\project_name\3_dsm_ortho\project_data.
  3. Delete the folder meditor.
  4. Open the project.
  5. Click Mosaic Editor.

Please let us know if the same problem remains. The meditor folder saves data which are created when loading the Mosaic Editor the first time, the links to images etc. Normally, when opening a project it makes sure that it knows where the images are stored and loads the inputs and outputs that should be displayed at the project opening.

Instead of moving the project manually, you could use the option from the menu bar Project > Save Project As… to avoid this error. This way you can eventually rename the project and you are able to set a new location. This will update all hidden paths in the result folders of the project.

Regards,

1 Like