Support Website Contact Support Blog

exporting triangle mesh - error e9036

I’m trying to export the triangle mesh from a project.  I have tried .dxf and 3d pdf.  I get an error message both time.

[Error]: Error e9036: GDAL error <4> `D:/Dropbox/Pix4dProjects/test-11jan2017/2_densification/project_data/test-11jan2017_texture.jpg’ does not exist in the file system,

[Error]: and is not recognized as a supported dataset name.

The .jpg file is there....I can see it, I can open it.

The .dxf file is produced but when I load it into a CAD package I get a white object.... no texture.

the 3d pdf file is just appears to be black, I cannot tell if something is there or not, but the file is produced.

Okay… I was wrong.  The file that DOES EXIST is in the 3d_mesh folder.  The message indicates Pix4d is looking in a different folder…it is looking in the project_data folder.  In that folder there is a .jpg file, with the same name EXCEPT it has _1_1 appended on it.

I copied the file “test-11jan2017_texture_1_1.jpg” file in the project_data folder to “test-11jan2017_texture.jpg” in the same folder (I just eliminated the _1_1 part of the file name).  I no longer get the error.

It also looks like I was wrong about the 3d pdf file…I deleted the file I had copied…I again got the error.  When I opened the 3d pdf file, I enabled editing and clicked mouse on the image…a few seconds later I did get a color image.

 

Hi Wesley,

Actually the error code that you saw is more a warning for the developers. It is not an indicator of good or bad processing.
It is something that should be hidden or more like a warning (in orange instead or red). At the moment it is kind of misleading for the users. This error message should be investigated only if the user experiences a crash or bug, otherwise feel free to ignore them.

Is it your case? Are you able to load all the results properly in the different view (rayCloud, Mosaic Editor…)?
Do you notice anything wrong when the processing of all steps is 100% completed?

Regards,

I am getting the same error message about:

[Error]: Error e9036: GDAL error <4> `C:/Users/Stu/Documents/pix4d/monty castle model 1/2_densification/project_data/monty castle model 1_texture.jpg’ does not exist in the file system, 

Resulting in blank white pdf files. I cannot seem to get a 3D model out of the software, and my trial is running out.
Please help !

Also this:

[Error]: and is not recognized as a supported dataset name.

Dear Stu,

Can the .obj be generated correctly? Have you tried generating the mesh at a lower resolution for the 3D PDF? Which software are you using to open the 3D PDF? We know the 3D PDF can be correctly opened with Adobe Reader. 

Best regards,

I exported a 3D pdf file for a building I had modeled. It won’t open in Adobe Acrobat. I keep getting an error message stating that a 3D parsing error has occurred. I’ve searched the internet for answers but haven’t found one. The file size a little over 114 MB. I would like to be able to give my client a file that they can view the 3D model of their building.

I did export at a higher resolution because the standard resolution was not very appealing to give to the customer but the higher resolution looks great.

Any suggestions.

Thanks,

Mike

@Mike

We met this error before and is because the file is to heavy. Try to downsize the maximum number of triangles progressively, export the mesh and attempt to open (e.g if you have 10’000’000 try with 8’000’000 and then if is not working with 5’000’000 and so on).

If you want to keep the high resolution I suggest you to use a third party platforms to share the 3D model results with your clients.For example Sketchfab. You can learn more about uploading 3D Textured Mesh results to Sketchfab at https://support.pix4d.com/hc/en-us/articles/204963595 or https://support.pix4d.com/hc/en-us/articles/203282189.

Cheers,