Support Website Contact Support Blog

Error - Failed to generate 3D textured mesh

Hi,

I try to do Project, Iuse Pix4dmapper Pro. This project I’m testing iI have already tried once whitout no problems. When I would try it again, i got error message. The first step is going well, But when the secound stage comes i get error messages.

Is says : “Error: Failed to generated 3D textured mesh”

I have tired to do different projekt and all got the same error message.

the projekt is aerial mapping, and it is about 300-500 image

 

Dear Johan,

We looked at your quality report that you sent us at support, and made some recommendations. We share them here for everyone’s benefit:

We would recommend processing with the 3D Maps template.

There seems to have been an issue with the camera optimization. This would explain the fact that there are several blocks in your project.

We would recommend processing with the Rolling shutter model. We expect this would help the calibration

https://support.pix4d.com/hc/en-us/articles/208460436-How-to-correct-for-the-Rolling-Shutter-Effect

Best regards,

Same problem here. I processed a batch and the results were ok. 

I tried to process again the same batch (same set of pictures, no change at all) and i got error: 

[Processing]: Exporting 3D Mesh

[Error]: Failed to generate texture to \</Users/miguelistan/Desktop/fotogrametría/catedral\_2017.05.05/catedral alta/2\_densification/3d\_mesh/catedral alta\_texture.jpg\>

[Error]: Exporting 3D Mesh failed!

[Error]: \>\>\>Exporting 3D Mesh\<\<\< failed with error (failed to run a step!)!

[Error]: \>\>\>Exporting 3D Mesh\<\<\< failed with error (failed to run a step!)!

[Error]: Failed to generate 3D textured mesh

[Processing]: Substep Dense mesh texture atlas tile finished.

This is not about camera calibration, this is a software issue. 

 

 

 

Hi Mika,

It might be that you ran out of RAM. The software requires to have at least 4GB of RAM available for processing. We would recommend rebooting the computer (to clear the RAM) and trying to process again (just step 2).

You can find our minimum system requirements here https://support.pix4d.com/hc/en-us/articles/202557289.

Hope it helps,

Hello,

I have same issue (starting: “Failed to generate texture to …”), but any of the above recommendations did not work. Could you please advice?

Hi Mateusz,

Hard to say right now what is going on.
Could you please upload your *.log file and the quality report of your project?
OneDrive

This should help us to understand what is going on.
What are your computer specifications?

Best

Many thanks for your quick response! Please see the uploaded files (folder: Mateusz Hudzik) as requested.

Hi Mateusz,

Not very used to troubleshoot on Mac OS since it is not supported since a while already.
However, I might have something:

Your project is located on a folder that contains special characters that are not recognized when reading the texture file.
This lead to the crash you experienced.
The solution would be to move (or save as in another folder) your project in a folder that does not contain any special characters.
Hope that this will solve your issue.

Best

Problem solved! Thank you Marco :slight_smile: