Mission checklist error " Drone Storage Error " Pix4D Capture Pro

Hi all, I have been using the Pix4D Capture Pro app for missions with a DJI Mavic 2 Pro without any issues for a while, both on a Samsung Galaxy S22 Ultra and on an iPhone SE 2nd generation. However, since last week, the drone won’t take off for a mission because of “Drone Storage Error” using either of the phones. I have tried the below things, but the issue remains unsolved so I would need help:

  • I have fully uninstalled and re-installed the app on both phones
  • I have tried a mission using Ctrl+DJI & Pix4D Capture (classic) and the issue does not occur on these
  • I have tried a different microSD card
  • I have reformatted both microSD cards using the DJI 4 GO app
  • I made sure I have the latest firmware (there has been no jump in firmware between before and when the issue occurred)
  • I have tried a new mission at a different location
  • I have reformatted the internal drone storage using the DJI Go 4 app

Hello there,

Cause for failure PIX4Dcapture_Pro_Mission_Checklist_Error.png

  • The camera storage reported an error.


  • Please try another card or try reformatting the card.

For more information visit, https://support.pix4d.com/hc/en-us/articles/10445879222557-Mission-checklist-PIX4Dcapture-Pro

1 Like

Thank you Kapil. Surprisingly, all three microSD cards I tried must have stopped being compatible with Pix4D Mapper Pro. On the pix4D community, I read that the SanDisk Extreme Pro cards (the previous 3 were older - they still work for other devices and for DJI4Go, just not for Pix4D Mapper Pro anymore) work best with Pix3D Mapper Pro, so I purchased one and this solved my issue!