Support Website Contact Support Blog

Pix4D Capture Not uploaded Mission to Drone

Using a DJI Mavic 2 pro. iOS ipad Mini running capture. Micro SD card is SanDisk Extreme 128 GB.
It has write speeds up to 90MB. iPad connected to internet via my iphone Tmobile hot spot. Working in Class “D” controlled air space with successful DJI custom unlock for the day. Drone flies fine with this unlock using DJI Go4. I loaded a polygon mission (rather large) and started. Drone flew a 3rd of the mission and then I paused to replace battery. When I tried to resume everything looked fine except the capture checklist could not / would not upload mission to drone. This continued all day despite my attempts to fix. I tried restarting, drone, app, ipad, controller, create completely new mission. Same result.
How do I get past this? What possible causes? Has the Pix4D capture been TESTED and proven to work in controlled airspace with DJI custom unlock? This cost me many hours of prep work and job payment. Pix4D please respond with recommendation.
Thank you.

Hello @christopher.oleary,

We have not tested the Pix4DCapture app in No-fly zones. If the area has been unlocked by the user in DJI GO, we would expect the mission to be properly flown but can’t guarantee it.

With that said, we do not know if his issue is really related to the No-fly zone, there might be multiple reasons that the mission would not be uploaded. It has been reported from multiple users, that using multi-battery for the bigger projects might have some issue. So, I would recommend creating a smaller project that can be covered with two batteries. If that doesn’t solve your issue, I would suggest you go through all the basic checks and troubleshooting steps as it will solve most of the issues that can be encountered if properly followed.

Regards,