Issue with Ctrl+DJI Permissions


Hi, I can’t get a connection to my P4Pro from my Samsung Tablet using Ctrl+DJI 1.9.10 and Pix4D Capture 4.11.0. I constantly get a screen popping up that says:
In order to control your drone, the SDK used in Ctrl+DJI which is provided by the manufacturer requires certain permissions. Additionally, it is necessary for us to be able to store images and flight data to your device’s location. Granting the permissions is required for normal operation.
I have given all three apps (Ctrl+DJI, Pix4D Capture, DJI Go 4) permission after permission until I’m blue in the face. But I can’t make that permissions pop up go away. I suspect that is the issue that is keeping me from connecting to the drone.

Any ideas?

Thanks.

Hello,

The behavior you are describing is new to us and has not been recently reported to us by other users. So, I would suggest you go through all the basic checks and troubleshooting steps as it will solve most of the issues that can be encountered if properly followed.

Pix4D is currently working on the next generation of PIX4Dcapture, which will be based on the current PIX4Dscan. PIX4Dscan has missions for mapping, 3D modeling, and inspection use cases. It is supported on Android and iOS devices. Download ‎PIX4Dscan on the App Store & PIX4Dscan on Google Play

In case the issue is not solved, I would also recommend you to go through our support article on Which image acquisition app can I use with Pix4D’s software?.

Do you have a list of android devices that you have tested to be compatible with Pix4D Capture? I am so, so, so tired of fighting this software and not being able to get it to work on a modern, updated android tablet or a modern, updated android phone.