Support Website Contact Support Blog

"Invalid or Unsupported Image File" when trying to open tiff in AutoCad 2017

I am trying to open .tiff orthos created with Pix4D in AutoCad 2017. When I drag and drop, I have an “invalid or unsupported imgae file” message. I followed the webinar (Create new layer, double click on it, drag and drop). Clients are getting anxious because they are not being able to work. 

Thanks.

I use attach command then I choose Image. Put it in the drawing without scaling or inserting in the coordinates. After that use the georefimg command (you must download that vlx) and everything works fine.

Hello Santiago,

Have you tried to open the .tiff file in a GIS software (like QGIS, ArcGIS, Global Mapper) for instance? Is the file loading properly?

What might happen is that the compression of the file is not correct.  You could try the following workaround:

  1. Open the mosaic in Irfanview.
  2. Click File > Save as…
  3. Save as Type: TIF 
  4. On the TIFF save options window select LZW
  5. Click Save.
  6. Open the LZW tiff file in AutoCAD.

Best Regards, 

3 Likes

But Pix4D advertises that I can export .tiff resulted from the processing into AutoCAD. Isn´t there a way I can avoid using a third software? On my folder I have the .tiff, .prj and .tfw files. I just processed another set of images and the same happens.

Also, no LZW file is generates (“TIF Save error” message on Irfranview). It´s kind of frustating… I can also do it on Global Mapper, but the idea is to avoid extra softwares, as advertised by Pix4D…

 

1 Like

I´m having the same problems! The full process is OK, but the .tiff doesn´t open un AutoCAD. When click “Properties” of the file, go to “Details”, on the “Image” section, there´s no “compression”. Then I testes a small portion of the dataset (using Processing Area) and the .tiff result works fine in AutoCad, and “Properties”-“Details”-“Image” section shows “Compression: LZW”. 

Original .tiff: 883MB

Processed Area .tiff: 24MB

 

I’m running into the same problem trying to get the GeoTiff into C3D. Did something break in the newer release? This was working great before. Used this process many times.

Hello everyone, 

@David, @Fernando @Santiago which version of the software are you using and which version of AutoCAD ? 

Could you please send us the Quality Report and the Orthomosaic by submitting a request here

Best Regards, 

I was able to correct the issue by breaking the geotiff into 3 regions.

so the issue is “big files”? you can only use small projects on AutoCAD?

If I have a very large project, I import the tiles and it works.

Sometimes the file is too large and my autocad version does not support it. Check the forum post: 

https://forums.autodesk.com/t5/autocad-lt-forum.

Max. 

Importing Pix4d work into CAD

First off: make sure you have a coordinate system setup in your dwg. This can be found in toolspace/settings/right click drawing title and go to edit drawing settings.

  1. Type MAPWSPACE in the AutoCAD Command Line
  2. MAPWSPACE Task Pane “On” hit ENTER
  3. Display Manager opens
  4. Click “Data” and “Connect to Data”
  5. Click Add Raster Image or Surface Connection.
  6. Name the Connection Type “Default is Raster_1”.
  7. Click on the Map button to the right of the source folder select source folder.
  8. Navigate to the folder where you stored the Orthomosaic tiles
  9. Orthomosaic is generated as a TIF. File.
  10. ORTHO information: Depending on the file size of the Orthomosaic you may want to import the tiles created for it.
  11. Tiles are smaller snips of the full size Orthomosaic
  12. Tiles are in the same location as the Orthomosaic but might not be created if the large Orthomosaic is small enough.
  13. Do not load the large Orthomosaic if the file size is greater than 300Mbs otherwise the drawing will have decreased CAD performance.
  14. Once raster folder is found click “CONNECT”.
  15. Once the images are connected go to EDIT Coordinate system
  16. Make sure coordinate system is NAD 83 State Plane East Zone US Foot (3435) if appropriate.
  17. Click on add “MAP LAYERS”.
  18. Map should load in less than in a minute
  19. (notes image usually reloads every time you zoom in or out) Its best to just pan around once you find a good height to work at.
  20. If your image in located in front of your linework go to draw order in the display manager and drag “map base” above all the images. (may need to save and reopen drawing to make it work.
1 Like

I am having this problem as well. I processed 494 pictures and ended up with an 800MB geo tiff. When I try to load it in AutoCAD it throws an error and also when I try to open with Windows Viewer. I have larger geo tiff’s that I regularly import into AutoCAD so I don’t believe the size is the issue. 

Does Pix4D have any solution to this? I am trying the software out and thus far I am less than impressed. 

Matt,

This is definitely not an image size issue. I just ran over 800+ images generating a 150 MB geo tiff image and it imports into C3D without a problem. My current thinking about this problem is that it has something to do with the image boundaries. I’ve started using the “processing area” to define the region I want to use in my project and ever since I’ve started using it I haven’t had a problem.

David

Hello,

Pix4D always compresses the orthomosaic to LZW, however, the problem seems to be related to the BigTIFF file when the project is quite significant (large orthomosaic).

AutoCAD probably does not know how to handle this BigTIFF variant and it results as if the orthomosaic was not LZW compressed. As a consequence, the large orthomosaic cannot be imported into AutoCAD.

There are two workarounds:

  1. load each tile of the orthomosaic one by one in AutoCAD.
  2. use QGIS to save the orthomosaic since QGIS is able to read BigTIFF file. It will automatically convert the orthomosaic to a “more classic” LZW compression format. QGIS is an open source software and can be downloaded from here: http://www.qgis.org/en/site/forusers/download.html
  • Open QGIS.
  • Drag and drop the non-transparent orthomosaic generated by Pix4Dmapper.
  • Right click on the corresponding layer and click Save As…
  • Once exported, drag and drop the new orthomosaic into the main view of AutoCAD.

Hope this clarifies the situation.

1 Like

Same problem here…i did a project with 1300 picturesand the orthomosaic was 3.5gb…autocad tells me that the file isn’t correct…although i can load the tiles but there are 71 of them…the point is to have one large merged photo…any other idies without extra software…??

What Marili said above worked for me:

  1. Open the mosaic in Irfanview. 
  2. Click File > Save as…
  3. Save as Type: TIF 
  4. On the TIFF save options window select LZW
  5. Click Save. 
  6. Open the LZW tiff file in AutoCAD.

I do have the AutoCAD lisp routine loaded named GEOrefIMG, that is mentioned here and elsewhere. I was previously not able to load a 2 GB tiff image into AutoCAD Civil 3D 2016 (use the “*_transparent_mosaic_group1” image). I was getting the same error message others were mentioning. After saving through Irfanview (freeware), I was able to bring the image in using the mapiinsert command. You need to have the index files in the same folder, the *.tfw and *.prj, I’m not sure which one is used or if both are used.It brought it right into my coordinate system.

1 Like

I have a large project that I’m creating quantities off of. The project was 1300 images and several acres. Rather than PIX4D merging the ortho images into a single one, I had it create tiles and use the “MAPIINSERT” with two i’s to insert the tiles into my AutoCAD (Civil 3D) drawing. This worked great, didn’t bog down my drawing and I didn’t’ have to reduce the resolution. 

At first, i had hundreds of tiles, but once I noticed the grid pattern, I didn’t need to insert all the tiles and it only took about half hour to get them into my drawing. The nice thing with MAPIINSERT command, it uses the coordinate system so you don’t have ot try to place them manually, just as long as you have the coordinate system setup in your drawing a head of time.

 

1 Like

 Would be great if the merge tiles file actually worked. I’ve got it to work in past but have had no such luck since i updated to 4.0.25 (and it wasnt fixed in 4.1.10)

this should be a simple process, Mapiinsert, select the single merged file and viola. Why does it have to be so difficult? 

1 Like

someone solved this issue? It’s really frustrating. Also with Irfanview it gives you error!!!