Support Website Contact Support Blog

Very large Pix4D OrthoMosaic not importing in Autodesk Civil 3D

Hello,

Our client provided us with an enormous (>7GB) Pix4D OrthoMosaic from a recent drone survey that will not import into Civil 3D.  The client for some reason did not tile the .tiffs. The image can be downloaded from the link below:

https://1drv.ms/f/s!AshJwvSEGv7qiowjxm42RogBoDmdDg

Researching this, it sounds like it is because of a compression factor being applied when generating the ortho-mosaic in Pix4D.  I found a thread listing some options to covert the .tiff to a non-compressed .jpg format.  The post listed InfanView as an option, which crashed on me when trying to export out.  I tried the 2nd option (Global Mapper), but it will not work either unless you buy a $600 license.  I have not tried QGIS yet, but I have ESRI ArcMap 10.5.1 and want to try using that.  Does anyone know the steps to convert the compressed .tiff from Pix4D to uncompressed with ArcMap and then export out “tiled” .jpgs that can be inserted more efficiently to Civil 3D?  Or can I open this .tiff in my Pix4D Mapper to parse it out to smaller tiles, so I can save them out to .jpg via the 3rd party options listed above?

Also, what is the status of fixing this issue in Pix4D itself?  Autodesk Civil 3D is a very popular platform that many of us use to analyze our Drone data.  It seems like these “extra” steps can be programmed away within Pix4D itself.  I am hoping the Pix4D developers are working on this???

Thanks,    

Hi Michael,

The tiles should be automatically generated in every project. I would recommend doublechecking the …\3_dsm_ortho\2_mosaic\tiles  folder and loading each individual tile in AutoCAD. 

Since the issue is related, as far as we know, to a single software (AutoCAD) and does not appear in other software (e.g. IrfanView, QSIG or Global Mapper.) we are currently not considering changing the way we are saving orthomosaics.

We dedicated our resources in order to better understand the issue and by processing several datasets concluded that the issue is most probably related to how AutoCAD handles large .tiff files. We did not experience any issues when importing results of smaller projects (smaller orthomosaics) but, on the other hand, faced the issue while importing results of larger projects (e.g. orthomosaics of more than 500 Mb).

To explain further:

  • AutoCAD does not handle very big files due to the size limitation. It might also depend on the version of the AutoCAD that you use, for example, we are facing the issue with AutoCAD 2017.

  • Moreover, we do not expect issues while importing the tiles or “smaller” orthomosaic (size of the file). For example, orthomosaic of 100mb should be fine. 

  • Pix4D always compresses the orthomosaic to LZW, however, the problem seems to be related to the BigTIFF file when the project is quite significant (large orthomosaic). AutoCAD probably does not know how to handle this BigTIFF variant and it results as if the orthomosaic was not LZW compressed. As a consequence, the large orthomosaic cannot be imported into AutoCAD. There are also other users reporting the issue and we kindly invite you to have a look and comment on the following post to get more insights: https://community.pix4d.com/t/2899

To import large orthomosaics into AutoCAD we recommend the following workflows:

  1. Load each tile of the orthomosaic one by one in AutoCAD.
  2. Use QGIS to save the orthomosaic since QGIS is able to read BigTIFF file. It will automatically convert the orthomosaic to a “more classic” LZW compression format. QGIS is an open source software and can be downloaded from here: http://www.qgis.org/en/site/forusers/download.html
  • Open QGIS.
  • Drag and drop the non-transparent orthomosaic generated by Pix4Dmapper.
  • Right-click on the corresponding layer and click Save As…
  • Once exported, drag and drop the new orthomosaic into the main view of AutoCAD.
  1. Use IrfanView:
  • Click File > Save as…
  • Save as Type: TIF 
  • On the TIFF save options window select LZW
  • Click Save. 
  • Open the LZW tiff file in AutoCAD.

Best,

Thank you for looking into this and confirming that this is an Autodesk issue centered around import constraints for very large .tiff images.

After some experimentation with Civil 3D v2018 and v2019 and research on the Autodesk Civil 3D forums, I found that converting the .tiff to .png format worked well.  We tried inserting various large .pngs between 5GB and 12GB into Civil 3D and amazingly it worked in all instances with little loss in resolution.  For now, we will run with “tiled” output from Pix4D (if we can control how the drone survey is processed…However, in the case above, we were provided the file).  If we get very large .tiffs in the future from outside our organization, we will use ESRI ArcMap to convert to .png format and insert into Civil 3D.  Perhaps consider including this as an option as well for others with a similar issue.  

Also, please note that I found IrfanView to crash when I tried to convert this large .tiff to .jpg. 

Anyway, thank you for your time. 

1 Like

Thank you for the additional information about the workflow you follow. I am sure also other users will appreciate it. 

As for the IrfanView, I also had cases when the software crashed while handling very large data and I prefer to use QGIS from that point on. 

Hi,

We created a post Error “.tif was not found or is not valid” when loading orthomosaic into Autodesk Civil 3D for this topic. 

This post will now be closed for comments and we invite you to use the new post for further discussion. 

Best,