Support Website Contact Support Blog

orthomosaic importation to civil 3D 2017

Hi

I’ve tried to import the orthomosaic created after all the 3 parts of the processing  have been executed.

I’ve tried once, obtained the orthomosaic and after the insertion in Civil 3D have failed (thinking that was a project problem),  I have created another project, processed the 3 steps and obtained another orthomosaic TIF.

Trying to insert the orthomosaic in Civil 3D the same problem with the general orthomosaic created !

As can seen when Raster1 was “add to Map” the coordinate system is “unknown”!

If I try to load an tile image from “C:…\pix4d\BARLOW\3_dsm_ortho\2_mosaic\tiles”, the image is loaded and the coordinate system appears (see picture “BARLOW ORTHOMOSAIC TO CIVIL3D_EX.PNG”) & (ex: BARLOW ORTHOMOSAIC TO CIVIL3D_tiles.PNG)

So I don’t understand what had happened with the first orthomosaic tif (812531 KB)

 

Thanks 

Alvaro Lopes

 

 

Hi Alvaro,

It is not very clear from the screenshots, are .prj, .tfw, .tif, .json files stored in the same folder? Could you please check if prj and .tfw files are not empty? 

Additionally, are you able to open orthomosaic with other software such as GlobalMapper or QGIS?

Regards,

 

Hi Marija

Yes files .prj, tfw and tif area in the same folder.

I can open the orthomosaic in GlobalMapper.

File prj has 534 kb

File tfw 76 bytes.

Thanks

 

Alvaro

 

 

Hi Alvaro,

 

Could you create a new support request: https://support.pix4d.com/hc/en-us/articles/hc/en-us/requests/new and send us the files (prj, .tfw, .tiff) so we can investigate?

Thanks,

It might be an Civil 3d problem.  I know I have had problems with Civil 3d for a few years now trying to import large tiff images.  I can import most tiff images, but ones that have a large file size I have problems with.

 I bring them into ArcMap and then export as a png file and Civil 3d will bring it in with no problems.

So maybe bring it into your Global mapper and export in a different format than tiff and see if that works. 

 

2 Likes

I import my ortho mosaics into AutoCAD regularly.  I use Carlson GIS rather than Civil 3D, but the issue is the same - sometimes the mosaic file is too big to handle.  In that case, I import the individual tiles one at a time.  They can be found in the folder …\3_dsm_ortho\2_mosaic\tiles

1 Like

Have you tried the command MAPIINSERT? I usually use this for my projects, it’s important to make sure the CAD drawing is set to the same coordinate system as the mosaic. 

1 Like

Robert is correct.  You need to use MAPIINSERT to import a geotif to the proper coordinates.  The other issue is that the geotiff is most likely too big and causing issues with civil 3d.  I use Global Mapper to export and .ecw file that’s compressed roughly 10:1 (maybe 7:1) then use _MAPIINSERT _command in civil 3d.

2 Likes

I use MAPIINSERT and set my import units to unitless and the image is placed in the improper position relative to my GPS Survey points.  I’ve also tried setting the units to metric/meters and it scales better, but not accurate.  What appears to be a metric to foot error.  The main concern is the scaling.  The photo appears to be close to scale, but when compared to ground control shots, it’s 3-4’ off.  The UAV we are using has survey grade PPK for cm accurate EXIF data.  Any ideas of what setting I am missing?

Hi,

We created a post [Desktop] Error “.tif was not found or is not valid” when loading orthomosaic into Autodesk Civil 3D for this topic. 

This post will now be closed for comments and we invite you to use the new post for further discussion. 

Best,