Support Website Contact Support Blog

Import problem orthomosaic

Hi,

I have a problem with the import of a orthomosaic :

As you can see, the orthomosaic is displayed in the timeline but it won’t appear at the 2D View

https://cloud.pix4d.com/site/61411/dataset/779271/map = this is the link of the cloud

https://we.tl/t-Z7b2l0XY75 = this is the orthomosaic

thanks for the information to fix this problem!

Hi,

This error is expected for outputs having a significant size and/or a complex geometry. In this case, the tiling process failed, meaning that the generated 2D output could not be split into smaller web maps (tiles) for several zoom levels and, for this reason, the output cannot be displayed. The output has been generated and indeed it can be downloaded from the Files > Results page of the project, but the file is too big/complex to be displayed on the 2D view of Pix4Dcloud.

So far, these are the variables that seem to be impacting the tile generation speed:

  • The significant size of the file (large surface and/or high resolution, a large number of points).
  • The complex geographic transformation from the project coordinate system to WGS84 that is used on web maps.
  • Corridor projects.
  • The multiple-blocks project, with not homogeneous tiles.

a) Some proposed solutions if you want to keep the same resolution:

  • The file can be split into multiple parts with some third-party software (here a link that shows how to do that) and then uploaded again in different separate projects on Pix4Dcloud.
  • The file can be replaced with a smaller one.
  • A processing area can be defined in Pix4Dmapper before uploading the project to Pix4Dcloud for processing.

b) If you don’t need the full resolution for the visualization, reducing the size of the orthomosaic itself:

  • By reducing its resolution in Pix4Dmapper before uploading to Pix4Dcloud (if the project was uploaded for processing from Pix4Dmapper)
  • On the Menu bar in Pix4Dmapper, click Process > Processing Options…
  • Select the processing step 3. DSM, Orthomosaic and Index.
  • Select the tab DSM and Orthomosaic.
  • In the section Resolution , increase the resolution to multiples of the GSD or to a customized resolution [cm/pixel].
  • After processing on Pix4Dcloud

Alternatively, you can download the orthomosaic from the Pix4Dcloud and reduce its resolution in QGIS:

  • You can sub-sample the orthomosaic following these steps:
  1. Right-click on the orthomosaic layer in the Layers panel. Then click Export > Save As…

  1. Select the option Rendered image , choose a destination folder and define a lower horizontal and vertical resolution, which by default is the current layer resolution. You can select the option “Add saved file to map” to check the visual difference in QGIS itself. Then click OK.

  • Then replace the file on Pix4Dcloud with the smaller one.

Hi Alice,

Thanks for the information but :

  • Resizing the orthomosaic is not an option because I don’t want to lose quality.
  • The proces area is already been set by the project boundary, so it can’t be smaller
  • Split the orthomosaic into 3 or 4 parts for example can’t be done because this orthomosaic is part of a series of measurements so I can not make a new site because the compare function wouldn"t work anymore

So I hope that you have an 4th option ? Because the things that you pointed out doesn"t solve the problem…

thanks

Reducing the resolution by half (ie 4cm to 8cm) will reduce the file size by a factor of 4. So you don’t have to reduce it a lot to make a big difference in file size. If you can get the final ortho to be in the 5gb range, it should work.

And I don’t think there’s a 4th option, unfortunately.

Hi @drone4,

As @Andrew_Milanes says, there is not a 4th option but I could notice that you eventually managed to display the orthomosaic. Did you downsample it?

Hi Alice,

I have an other problem with an import of an orthomosaic (from 3th party software)

I have already reduced the resolution to 5cm to become a size of 700MB, So i can import the orthomosaic.

But Pix4d Cloud doesn’t recognize the coördinate system… It changes also the scale

here is the link of the datasheet = https://cloud.pix4d.com/site/61409/dataset/779274/map

The problem is at the data from the 31th of october. At 28 august, I import the same orthomosaic from a 3th party software. Then it worked, now it doesn’t…

the specs of the orthomosaic:

These are the same as the orthomosaic from the 28th of august.

thanks !

Gregory

Hi Gregory,

I could notice that, when importing the orthomosaic file of the 28th August, QGIS didn’t ask me for any coordinate system transformation definition and that the counts on the bands look like this:

whereas when I import the file of the 31st October, QGIS does ask me which coordinate system transformation I want to apply and the counts on the bands look a bit different

Therefore I don’t think the files are identical in terms of coordinate system and bands.

As said in the past, we fully support the import of photogrammetric outputs that are generated by Pix4Dmapper only at the moment, but I hope this information might be helpful to you to solve your issue.