Support Website Contact Support Blog

Orthomosaic and DSM size limit

Is there a size limit on both orthomosaic and DSM?
If so, what is it?

I tried importing a processed project onto Pix4DBim, but only the point cloud and mesh was accepted.



Hi @Lieven_Emonts-gast,

Please refer to this article:

For technical reasons, it is not possible to process more than 4000 images. (Monthly users that have a Cloud allowance of 2500 cannot process more images than this).

However sometimes projects having less images cannot be processed neither. It mostly depends on the project and it is hard to say if it will be successful or not.

Hope this helps.

Hello @Marco

But what is the limit of offline processed orthomosaic/dsm’s to upload to the Bim-cloud?


Hi @Lieven_Emonts-gast,
The orthomosaic failed during tiling. This error is expected for outputs having a significant size and/or a complex geometry. In this case, the tiling process failed, meaning that the generated orthomosaic could not be split into smaller web maps (tiles) for several zoom levels and for this reason, the output cannot be displayed on the map view of the Cloud platform. Usually the limit is around 6-8 Go depending on the geometry complexity.

The options you have in your case are either:

a) If you don’t need the full resolution for the visualization, reducing the size of the orthomosaic itself:

  • By reducing its resolution
    Before uploading to the Cloud
    After processing step 2. Point Cloud and Mesh , change the Ground Sampling Distance (GSD) of the Orthomosaic.
  1. On the Menu bar, click Process > Processing Options…

  2. Select the processing step 3. DSM, Orthomosaic and Index .

  3. Select the tab DSM and Orthomosaic .

  4. In the section Resolution , increase the resolution to multiples of the GSD or to a customized resolution [cm/pixel].

    Reduce its resolution in QGIS:

  • Open the .tiff file in QGIS.
  • On the top bar, navigate to Raster > Conversion > Translate (Convert Format).
  • Select input layer and output file location and name.
  • Check “outsize” and select the percentage to which you want to reduce the Ortho resolution.
  • Click OK
  • Then replace the file on the Cloud with the smaller one.
  • By reducing the project area
    After step 2. Point Cloud and Mesh is processed, draw a Processing Area . This will reduce the project area for which the results of step 3. DSM, Orthomosaic, and Index are generated, but the quality of the outputs is not affected.

b) Tiling the orthomosaic in different files with third-party software and uploading them as results in different projects.

Hey @Marco, thanks for your help.

I reduced the resolution of the mosaic to 2xGSD. This makes a big difference in file size, but some areas are now black" Any advice? It seems like this only happened to the area of one of the 3 projects i merged into this project. It looks as if the overlap between flight lines is now too little, however this was the same as the rest of the project and was no problem with 1xGSD.


Hi @Lieven_Emonts-gast,

Seems that the difference of GSD between the two projects has an impact when decreasing the global GSD.
Without testing and the project it is hard to say. I would rather recommend you to reduce the size using QGIS…^^

Hey @Marco

I tried the QGis software.
My original orthomosaic was 3,5GB
When using QGis and selecting 50% outsize the file becomes 8GB…
When using QGis and selecting 25% outsize the file becomes 2GB

So my resolution is 4 times less at this time, which is not how i want to share the orthomosaic.
Seems odd that the file becomes 2 times the size when selecting 50% resolution…