Support Website Contact Support Blog

Images not displayed from GCPs selection in Tie points (Pix4D v2.2)

 Hi,

Have anybody worked with the newer version (2.2) yet? I suspect there is a bug in the newer version where the respective images aren’t displayed anymore when clicking on a GCP from the dropdown list in the left widows. 

In other words… After inserting the GCPs via GCP manager, it will display in the drop down list, but afterwards if you select one of them from the list, the connected aerial images won’t display in the right-hand side window so that you can tag the precise locations. Also displayed by the following image.


Can someone confirm if this is a bug, or if the functionality just have changed with version 2.2? I hope it is not the latter, because I really don’t like inserting new GCPs via the point cloud method. 

Hi Brian,

Are you flying a DJI drone?
If so, there is probably a vertical shift for the images that can reach 100 meters. The GCPs are at the correct altitude but not the images. The difference is actually so large that the software is not able to connect the two and to display the corresponding images where the GCPs are supposed to be.

In this case, we recommend the following. Once the project is created and the images are imported:

  1. Run step 1. Initial Processing.
  2. Create 3 Ground Control Points (GCPs) manually using the right sidebar of the rayCloud. The mark of these GCPs should correspond that of GCPs that are intended to be imported later. For more information: https://support.pix4d.com/hc/en-us/articles/202560109
    For each point that is manually added:
  • In the Label field, write the name of the GCP and make sure it is the SAME as the one written in the input GCP file containing the coordinates.
  • In the Type field, select 3D GCP or 2D GCP from the drop-down list.
  • Do NOT edit or enter the point coordinates.
  1. Import the GCP coordinates into the project from the file using the GCP/MTP Manager.
    For more information: https://support.pix4d.com/hc/en-us/articles/202560039
  2. Just after importing the coordinates a window pops up. Click Yes to All, so that the previous coordinates of the 3 GCPs that were created are replaced with the information contained in the input file.
  3. On the Menu bar, click Process > Reoptimize. The model should adjust to the 3 GCPs.
  4. Mark the other GCPs (if any) in the rayCloud following: https://support.pix4d.com/hc/en-us/articles/202560769

Let us know if this does not fix the problem.

Regards,

I am running into the same issue. I am really unclear on step 2, how would I exactly mark manual GCP without importing actual GCP csv file, and again on step 3 import the CSV file?

Seems to be very confusion, I am afraid that I might cause some accuracy error without knowing exactly following the correct steps.

Hi,

This case is indeed not easy to handle. To clarify the situation, there are three features for a GCP:

  • The coordinates measured on the field (GPS device): blue circle. (1)
  • The mark of the GCP (user): yellow circle plus cross. (2)
  • The computed position (software): green cross. (3)

The typical workflow is to import (1) before doing (2). Here the workaround is to do (2) before (1). It is important to understand that the user mark should not be positioned based on the measured points but on the visual content, meaning the GCP target captured by the images. The idea is to put the mark based on the pixels. Then the software computes the 3D projection of the GCP on the model and creates (3) by using (1) and (2).

Therefore it makes no difference to do (2) before (1) since the mark relies solely on the image content. Good marking means high zoom level (the larger the yellow circle, the more confidence in the mark), good texture on the image, clear target, good image resolution and no user mistake. Of course after step 1, the calibration of the project should show that (1), (2), (3) match each other.

Hope this clarifies the situation.

Hi All,

I recently updated to 4.2.27 and I am having a different problem with my GCP images not showing.

As you can see below, Pix4D has correctly found and located the images associated with my point but can not load the images for me to mark them. I did my flight of the field in 3 separate flights and the eastern and western sides processed easily and perfectly. I’ve tried basic trouble shooting with my computer but no luck. 

Has anyone had these issues before? Any ideas of how to fix this?

@Alexander, thank you for sharing a screenshot of the rayCloud.

It looks like you are unable to see your ground control points in your images for a different reason than Brian. In Brian’s case, the images did not appear in the Properties Menu because of a significant discrepancy between the images’ computed position, which was largely defined by the images’ geotag, and the ground control points’ initial position, which is defined by the measurements that you collected onsite.

I anticipate that you do not see any images in the Properties Menu because Pix4D Desktop is not normalizing the images correctly for the sake of visualizing them in the software’s interface. If that is the case, you can get back up and running with the following modifications to your project’s .p4d.

  1. Save the project and close Pix4D Desktop
  2. Open the project’s .p4d file with a text editor, e.g. Notepad
  3. Find the <cameraModelSource> line and enter the following string directly above this line:
    <pixelValue pixelType="uint16" min="0" max="0"/>
  4. Save the modified .p4d file and close the text editor
  5. Launch Pix4D Desktop
  6. Reopen the project via the modified .p4d file
  7. Verify that you can see the image content in the image thumbnails in the Properties Menu by selecting a ground control point or in the rayCloud's 3D environment (you'll notice that all of the image thumbnails are black in the rayCloud's 3D environment in the screenshot that you shared).

If you do not see any difference in the visualization of your images, please process Step 1 again so that the new image normalization can be taken into account. The recommended modification should enable you to see your image content and should have no effect on your project's results.

Please let us know if you can see images in the Properties Menu after changing the project's image normalization settings.

Hi Andrew (and Others)

Please help, I have attempted the trouble shooting you suggested and I am still having the same problem. As you can see below, I edited the max value to zero, I then saved and closed the project. Upon reopening it did not work so I reran step one. The error remains. Please advise what next steps I can take. This issue has appeared on other projects of mine and I am unable to finish processing with out verifying my GCPs.

Hey Alexander,

You need to move <pixelValue pixelType=“uint16” min=“0” max=“0”/> down one line, so that it is just above “<cameraModelSource>”.

Also, ensure the <pixelValue> line matches this.

Let us know how it goes!

Hello All,

Thank you for your assistance, however, changing the line order has seemed to cause a fatal error in the project. It will no longer open and sends the following error. I am running Pix4d desktop version 4.2.27. Do I need to update anything or use Pix4d Desktop preview instead to be able to make these edits to the project file?

[Info]: Active GPU

[Info]: Device string: NVIDIA GeForce GTX 1070 Ti

[Info]: Provider name: NVIDIA

[Info]: ChipType: GeForce GTX 1070 Ti

[Info]: Driver version: 23.21.13.9077

[Info]: Memory size: 4293918720 bytes

[Info]: OpenGL version: 4096

[Info]: OpenGL flags: 3

[Info]: loading project file: C:/Users/Public/Pictures/pix4D/RusselRanch/RR\_20180509\_East\_Multi-REDOAfter.p4d

[Processing]: ProjectLoading

[Info]: XSD Validation - description: \<html xmlns='http://www.w3.org/1999/xhtml/'\>\<body\>\<p\>Element \<span class='XQuery-keyword'\>pixelValue\</span\> is not defined in this scope.\</p\>\</body\>\</html\>

[Info]: type: 3

[Info]: location: file:///C:/Users/Public/Pictures/pix4D/RusselRanch/RR\_20180509\_East\_Multi-REDOAfter.p4d line: 221 column: 64

[Error]: XML file validation failed with XSD: C:/Program Files/Pix4Dmapper/resources/xsd/19/pix4d.xsd

[Error]: Error e0400b: Cannot open project C:/Users/Public/Pictures/pix4D/RusselRanch/RR\_20180509\_East\_Multi-REDOAfter.p4d. Invalid format.

Has this issue been solved? I’m having the same problem. I followed the instructions above but it doesn’t work.

The camera sensor is Micasense RedEdge. The camera firmware has been updated to make it compatible with Pix4D Fields. However, processing is being done with Pix4DMapper at this time.

 The problem seems to be specific to the Micasense RedEdge since the images under Properties display properly when processing another camera (regular digital camera).

 I notice that when I click on rayCloud error messages appear in the Log Output window. From the message, it seems that extra texts are added to the name of the images located in the “thumbnails” folder (see attached). Could this be the reason why the images are not appearing?

 

Hello Riogel,

When you change the p4d file and add the line <pixelValue pixelType=“uint16” min=“0” max=“0”/> , it is also needed to process Step 1 again in order to generate the thumbnails and normalized images again. You should delete the existing Thumbnail and normalised folders under 1_initial>project_data.

Please let me know it works now.

 

I have the same issue and I have followed the above steps and it did not work. are there any other suggestions ?

Thanks,

Mustafa Alhakeem

 

 

Hi Lance,

Your case is different.

It has to do probably with the wrong altitudes registered with DJI drones. Are you flying a DJI drone?

If so, there is probably a vertical shift for the images that can reach 100 meters. The GCPs are at the correct altitude but not the images. The difference is actually so large that the software is not able to connect the two and to display the corresponding images where the GCPs are supposed to be.

Please set up the correct flying altitude before running step 1 by typing them in the Image Properties Editor.

Another solution could be to measure the GCPs in the Basic GPC/MTP editor before running Step 1. More informatioon can be found here.

Let me know if that helps.

Thank you very much.

 

 

This problem is a constant occurrence with a BS work around from your support team. For over $3000/year, a fix should be given that allows the tie points and photos to be adjusted vertically. In the end it doesn’t even matter, because all we want to do is tie into our ground control.

Thank you for the feedback.

I will pass it to the developers to see a solution could be implemented.

For now, the current workaround has to be done.

Thank you very much.

Riogel Torres,

Regarding your issue (https://community.pix4d.com/t/5532/comments/360002121292) where Pix4D prepends extra characters to images in ‘thumbnails’ and ‘normalized’ folders. The only solution I found is to rename all images in these folders to what Pix4D expects to see. In your case you should prepend ‘000_’ to all your imagery in  ‘thumbnails’ and ‘normalized’ folders. This is not the most elegant solution, but a working one.

I hopes this helps,

Cheers,

Yuri

I’m using 4.4.12. I had a problem with the thumbnails showing up in order to coordinate the GCP’s. My problem doesn’t have anything to do with needing to change the p4d file in notepad or an error with DJI’s photos.

I performed 3 different flights for this site to test out different survey methods with my Phantom 4 RTK. I did a 3D Photogrammetry flight at 200 ft AGL, and two 2D Photogrammetry flights at 200 ft AGL and 82 ft AGL (the lowest that the program would allow me to go). I had no problem when selecting the points in both 200 ft flights, but suddenly having the problem with the 82 ft flight.

After investigation I found that my localized elevations for my GCP’s (around 350 ft) are above my WGS84 flight elevations (320 ft). I tested my theory by adjusting one of my GCP elevations to below my flight elevation. Sure enough, the thumbnails for that GCP appeared while the others above my flight elevation still don’t. Also, after I marked the adjusted GCP on the photos and I changed the elevation back, the thumbnails still show for that one.

I guess the work around is to give the GCP’s a temporary elevation that is below the flight level and then adjust them back up to their actual elevation after selecting the points in the photos.Pix4D%20GCP%20Thumbnail%20Error%20Screenclip_LI

UPDATE:
The above workaround sort of worked - I got one thumbnail to show up for the remaining GCP’s after lowering their elevation below the flight level. I then tried using the Basic Editor in the GCP/MTP Manager to mark the points on 2 photos each in order to hopefully enable the Automatic Marking feature in the RayCloud Editor. It worked. When I went into the RayCloud Editor all of the marked and unmarked thumbnails showed up when I selected the various GCP’s.

1 Like