Support Website Contact Support Blog

No image - GCP marker

When I choose my RTK GCP in Manual/GCPs Display Properties I don’t see any images that show my ground marker.

How do I fix the GCP on an image if none are displayed in the Images box?

Hello Robert,

If the images have or no geolocation, in both cases, the Basic GCP/Manual Tie Point Editor does not display on which images may be present the GCP. But The rayCloud, after the step 1, display automatically the images where a GCP can be found (once the GCP and its coordiantes are included)

So we suggest you the method A if your images have geolocation. And the method B if your images do not have geolocation. In both cases, basically it is needed to mark them in the rayCloud after the Step 1.For step by step instructions and more information:

https://support.pix4d.com/hc/en-us/articles/202560239

Regards,

I have come across situations when selecting GCP in the rayCloud AFTER Step 1 and pix4d was showing me images where my GCP was not visible at all.
The green cross was seems like randomly pinned in an image.

Regards,
Vusal

Hi Vusal,

The possible causes for this problem is:

  • Bad calibration of the cameras. This is something you could check in the Quality Report and the rayCloud.
  • Bug of Pix4Dmapper. It should be solved with the latest version of the software, as we do not have any known issues with the current version (1.4.46: https://mapper.pix4d.com/download/)

Best regards,

I, too am haiving a similar problem. No images found that contain my GCPs - I’ve followed the supprot articles and checked coordinate systems - Did the OP ever find out why this was happening?

Hi Ben,

Could you give these suggestions a try to solve the problem and let us know?
https://support.pix4d.com/hc/en-us/articles/206544136

Regards,

I’ve flown about 80 projects with an Sensefly Ebee drone with post flight processing completed with eMotion 2 & 3 which creates a .pix4d file before even opening Pix4D.  I’ve never had a problem with the GCPs and whether or not they showed up in any images.  I’ve recently purchased a DJI Phantom 4 Pro and have flown about 10 sites with no post flight processing.  With a DJI flown site, I start a new project by importing images which have been geotagged (I know this because they show up reasonably close to the correct horizontal position in the map view).  However the vertical “Z” coordinate is usually several hundred feet off.  As a result, when I run GCP manager, the GCP doesn’t show up in the images.  I have discovered if I change the elevation to zero and hit apply, the GCP will show up in the images.  I then enter the correct “Z” coordinate, mark the GCP on a couple images, hit “Apply” and I’m back on track.  I can’t help but think that I’m doing something wrong though.  I’m either misinterpreting the coordinate conversion (I’m assuming the DJI is georefencing the WGS84 coordinate system) or there may be a glitch in Pix4D.  Does anyone have any ideas or have flown the DJI with seemless results?      

 

Thanks.

Hi Robbie,

The images that are saved on the drone’s SD card are geotagged by DJI. Lat./Long. coordinates are reliable in the image EXIF, however, there might be some inaccuracies for the altitude depending on the location where you are mapping. We made testing in our office here and we found that the vertical coordinate is off by several meters that can reach an error of 100 meters. Some users noticed the same. Note that this is just an offset meaning that the within the model, the accuracy is not affected, only the absolute location is.

As a consequence, we always recommend to process with ground control points (GCPs) in order to fix these uncertainties. If you have issues to mark the GCPs in the rayCloud because of vertical shift, click here. If you do not have GCPs, please refer to this procedure.

The coordinate system used by DJI is indeed WGS 84 with egm96 for the vertical reference.

Once the model adjusted, if you want the model to be visually pleasing in the rayCloud, e.g. without long rays linking the blue (wrong / initial) and green (corrected / computed) camera spheres, it is possible to edit the image vertical coordinates and to re-optimize the results so that they will be displayed closer to the accurate position. Check Method A of this article.

Cheers,

I had the same problem, I fixed it by using the Basic Editor of the GCP/MTP Manager  and marking each GCP on three images, hit Reoptimize, after that they started to show up in the rayCloud and the Automatic Marking option was available, hit it, and more images showed up to be able to be marked with the GCPs, I marked few more, hit Reoptimize, and I confirmed in the raycloud graphic the elevation of the model was fixed with the GCPs. some screenshots below.

 

model relative to GCPs before the fix:

 

model elevation before the fix:

 

Basic Editor:

 

verifying model elevations after fix (average ground elevation is around 435m), GCP #13

 

elevation on a model´s point closed to GCP #13

2 Likes

Thanks for sharing and illustrating your solution Roger!