Support Website Contact Support Blog

GCP Photos not showing up in Raycloud

Hi, I know others have had this issue but their solutions have not worked for me. I used a Phantom 3 Pro last week and everything went well. Yesterday I used a Phantom 4 Pro for the first time and that’s when I ran into issues. I believe my coordinate systems are ok since the images and gcp’s all come up in the correct general location in map view but then I cant mark the aerial targets on the photos in the Raycloud editor. Any ideas?

Amy

Hi Amy,

Could you please attach some screenshots from the rayCloud? Are the GCPs at the correct X,Y location, but at a different altitude (Z)?

Could you also attach screenshots from the quality report where we can see the coordinate systems and the quality check?

Thank you

DJI drones record altitude information using the barometer and can be inconsistent. You’re not doing anything wrong.  There’s two common workarounds. 

  1. Change your image altitudes to something 10’-200’ above your GCP altitudes, using the “image properties editor” in Pix4d.   I’m not a fan of this method or changing any of the metadata in the images, but it works. 

 

  1. In your map view, click on one of your blue GCP crosses. When the dialogue box pops up, click “Basic Editor”, and  mark the visible target in 3 images , then click OK.  Do the same thing for two more targets.  Once you have  3 targets, with 3 marked images each , go up to your top “process” menu and reoptimize.  After the reoptimize is complete, you can mark the rest of targets & images using the raycloud editor. 
1 Like

The workarounds proposed by Derrick are valid and he is right that, normally, the issue comes from the altitude information provided by the drone. 

Thank you Derrick :-)

Having some screenshots and the quality report could help us to better understand the case