Support Website Contact Support Blog

DJI Inspire 1 Pro X5 and Pix4D GCP Issues

We are looking at purchasing Pix4D however getting the GCP to work correctly with our equipment is coming quite the challenge.

As you can see in the image the GCP is located above the images, also when I click on the GCP icons no corresponding images populate to allow me to select them? 

 

Thanks for the help,

Justin

 

 

Hi Justin,

The images that are saved on the drone’s SD card are geotagged by DJI. These coordinates are the same of that in the .p4d file generated by our mobile app, Pix4Dcapture. Regarding the Lat./Long. coordinates, the drone’s GPS saves reliable information in the image EXIF. However regarding the altitude there might be some inaccuracies depending on the location where you are mapping.

We made testing in our office here and found that the vertical coordinate is off by several meters that can reach an error of 100 meters. Some users noticed the same. Note that this is just an offset meaning that the within the model, the accuracy is not affected, only the absolute location. As far as we know, the issue has remained until now.

Therefore, Pix4Dmapper cannot find the images where the marks of the GCPs are supposed to be because the vertical shift between the model derived from the images and the GCP coordinates are too different. To solve the problem, we would suggest the following. Once the project is created and the images are imported:

  1. Run step 1. Initial Processing.
  2. Create 3 Ground Control Points (GCPs) manually using the right sidebar of the rayCloud. The mark of these GCPs should correspond that of GCPs that are intended to be imported later. For more information: https://support.pix4d.com/hc/en-us/articles/202560109

For each point that is manually added:

  • In the Label field, write the name of the GCP and make sure it is the SAME as the one written in the input GCP file containing the coordinates.
  • In the Type field, select 3D GCP or 2D GCP from the drop-down list.
  • Do NOT edit or enter the point coordinates.
  1. Import the GCP coordinates into the project from the file using the GCP/MTP Manager.
    For more information: https://support.pix4d.com/hc/en-us/articles/202560039
  2. Just after importing the coordinates a window pops up. Click Yes to All, so that the previous coordinates of the 3 GCPs that were created are replaced with the information contained in the input file.
  3. On the Menu bar, click Process > Reoptimize. The model should adjust to the 3 GCPs.
  4. Mark the other GCPs (if any) in the rayCloud following: https://support.pix4d.com/hc/en-us/articles/202560769

This should solve the problem.

Regards,

 

I tried this method and nothing shows up?  It over wrote the 3 GCP with no values and it added in my 4th one.

 

I went through the basic editor and click on all the images showing the panel markers. Then reoptimized and the point cloud is really

messed up now.


 

well I finally got 1 picture to show in the gcp images list but the ray cloud still will not register to

the control points.  Anyone know what I’m doing wrong? Hoping to figure this out before dropping $8k plus on software

I cant use with my equipment.

 

Hi Justin,

Have you tried the suggested workflow?

We recommend that you remove the GCPs you added in the first place before creating and marking new ones as suggested.
After removing the GCPs, reoptimize the project to make discard the previous adjustment: on the menu bar, click Process > Reoptimize. Then the follow the procedure above starting from 2.

In the first screenshot in your second reply, we still see the blue GCPs marks up in the air whereas if you created manually and marked the GCPs “1”, “2”, “3” and “4” we should be able to see them on the model and to see the number of marked images on the left sidebar next to the GCPs’ names. Note that for the marking to be effective, either using the rayCloud or the Basic Editor, it is necessary to be on at least two images.

Regards,

 

This is a pretty common problem its seems. Anyway pix4d can make a video on how to fix this issue? These instructions are pretty confusing.

 

I finally figured it out. Best thing to do is go into the image properties and export the geotags into a csv. Once you do that edit the Z values to reflect the difference in the point cloud and the GCP. With that you can add the difference to the Z elevations on the csv file, after that import the new geotag values inside the images properties. Now when you bring in the images it will be close enough to the GCP z elevation that you can now select them in the raycloud.

 

Thanks,

Justin

Pix4d Support,

I’ve tried the method mentioned above without any success half a dozen times, I am now going to try Justin’s method.

If there is any update on how to correct this better please let me know.

 

Thanks,

Aubin

Hi all,

To clarify the situation when dealing with offset because of inaccurate vertical coordinates, there are two ways to adjust the model:

1. Using points with accurate vertical coordinates and including them into the project as GCPs.

1.1. Ideally these points are actual GCPs measured on the field with accurate GPS device.
More information about getting GCPs: https://support.pix4d.com/hc/en-us/articles/202557489  
More information about including GCPs: https://support.pix4d.com/hc/en-us/articles/202560239

1.2. These points can also be obtained from a Web Map service but it will be less accurate.
More information on how to proceed: https://support.pix4d.com/hc/en-us/articles/115000778603#label2

NOTE: In somes cases because the vertical shift is too large, the software cannot match the points and the model so it is not possible to mark them in the rayCloud. This article will then probably help: https://support.pix4d.com/hc/en-us/articles/206544136
You can also check our video on the same topic: https://www.youtube.com/watch?v=539e7la_zzo

INFO: Once adjusted, if you want the model to be visually pleasing in the rayCloud, e.g. without long rays linking the blue (wrong / initial) and green (corrected / computed) camera spheres, it is possible to edit the image vertical coordinates and to re-optimize the results so that they will be displayed closer to the accurate position. For more information: https://support.pix4d.com/hc/en-us/articles/115000778603#label1

2. Editing the image vertical coordinates. It is a good option if the image vertical coordinate is constant during the data acquisition, e.g. grid horizontal flight. The true absolute altitude of the images is assumed to be known.
More information on how to proceed: https://support.pix4d.com/hc/en-us/articles/115000778603#label1

It is true that there are quite some cases where there is an offset between the image geolocation position and the generated model. The procedure on how to deal with this is also described in this video: https://www.youtube.com/watch?v=539e7la_zzo

Hope it clarifies the situation.

Regards,