Support Website Contact Support Blog

8 GCP's all pointing to same image.

Community and Support Team:

I am experimenting for the first time with GCP’s and have successfully uploaded them following the GCP webinar. However, after they are imported, each GCP is referencing the same exact photo.

I tried to match up my Photo Properties editor, Output Coordinate System, and GCP Editor Coordinate System. None of these attempts have been successful. There are millions of keypoints in my project (515 total images) and I can easily identify my GCP’s. Likewise, my GCP import is correctly positioned in the pointcloud. Nevertheless, despite being correctly positioned in the pointcloud, each GCP is still pointing to the same exact image (where there is no GCP whatsoever).

UAV: DJI Phantom 3
Image Coordinate System WGS84 (egm96)
Ground Control Point (GCP) Coordinate System NAD_1983_StatePlane_South_Carolina_FIPS_3900_Feet
Output Coordinate System NAD_1983_StatePlane_South_Carolina_FIPS_3900_Feet

If I change the Image Coordinate System to anything other than WGS84, it generates an error since all of my images have been tagged in that naming convention.

Any assistance is appreciated.

Tom Fernandez, CEO
SkyView Aerial Solutions LLC
Tom.Fernandez@skyviewaerialsolutions.com

Tom,

You must mark each GCP in the Basic Editor on several images ( I do 3 images each GCP) before you can mark GCP’s in ALL images using the RayCloud Editor.  

This may not be your problem, but it would cause a similar situation.  

Thank you, Ryan. Unfortunately, I am not getting multiple images for each GCP. Every single GCP is giving us the same single image which is not related to the actual GCP in the field. For example, our GCP’s are two separate white X’s on a black square on the bottom left and top right of our ortho. I imported the GCP’s per the marks we made and when I select them in our pointcloud, they reference a barn that is on the opposite side of the field. We have 8 GCP’s and every single GCP is pointing to the same barn.

I will upload screenshots of the issue later.

Best.

Tom,

When you open the Basic Editor, all your images will be in camera list.

You wont be using the point cloud at all.

 

Click Project / GCP Manager /  then BASIC EDITOR at the bottom right corner of the popup window.

All images “should” be in the list in the Basic GCP Editor popup.

Highlight a particular GCP from the top list, then find a corresponding image from the Image list on bottom and mark it.  Mark at least 3 images per GCP in the Basic Editor before using the RayCloud Editor to mark all images for each GCP.

I hope this helps.  

 

 

 

 

 

I had the same issue and I’m using a DJI Phantom 3 as well. What I found was that when I brought the images in they were at elevations of ~100’ above sea level. The site I was mapping was Missouri NAD83 and had GCP elevations around 1000’ above sea level. What I found was that if you lower the GCP elevations closer to the image elevations it will recognize them in the images. After its recognized then edit the GCP elevations back to what they were originally. You can then re optimize and it should move the point cloud to the GCP elevations. It just appears that the GCP’s and the images are too far apart is why they aren’t recognized.

Dear all,

If the project has image geolocation, then when importing the GCPs, they will correctly project on the model in the rayCloud. In this case, it is easy to mark them in the rayCloud and reoptimize so as to be taken into account: https://support.pix4d.com/hc/en-us/articles/202560769

If the project does not have image geolocation or the vertical coordinate systems of the image geolocation and the GCPs do not agree, the GCPs will not project correctly on the images, so they cannot be marked in the rayCloud.

In the case that Brett describes, it seems that the image geolocation altitude is Above Ground Level, whereas the GCPs altitude is Above Sea Level. Therefore, the GCPs do not project correctly in the images in the rayCloud. In this case, you can mark 3 GCPs in the Basic Editor so as to adjust the model to the GCPs vertical coordinate system. Then, the rest of the GCPs will project correctly and you will be able to mark them taking advantage of the rayCloud.
For step by step instructions on how to mark the GCPs in the Basic Editor: https://support.pix4d.com/hc/en-us/articles/202560099

@Tom: Could you confirm that the image geolocation latitude and the GCP altitude refer to different surfaces?

Best regards,

 

I am having issues with GCPs in the Ray Cloud, and how the instructions are written in the help for GCPs. I have a set of images that are all geolocated, and have RTK survey grade GPS data. According to how the directions are written in the help for option A, we bring in the .txt file of our GCP data, and then run the initial processing without marking any images. This results in having the same set of rejected images showing up in the ray cloud, without any of the GCPs even showing in there. 

Our work around to this is to ‘train’ the GCP marking by indeed marking 3 GCPS (out of 8 total) in some images before doing the initial processing, but this is not in line with the directions, and is a bit of a pain. Or we locate the images in the map view after the initial. I repeat though, not locating images and just bringing in the GCP file does not work.

I would like to know if these directions are wrong, or if there is a key step I’m missing.

Perhaps there is something wrong with the GCP coordinate system…
You could check and try to change some settings here: https://support.pix4d.com/hc/en-us/articles/202560029

If you can see the red points corresponding to the images on the top of a satellite background in the Map View, this probably means your image coordinate system is good.

It seems possible to follow Method A even if the the two coordinate systems are different.
But when I encounter problems to add GCPs, I usually refer to the page: https://support.pix4d.com/hc/en-us/articles/202560099

Perhaps I was not clear before with the background details. Yes - the GCPs and the image coordinates are in the same projection, with the same datum. This was cross referenced with ArcMap 10.3, and we even performed an RMS analysis within the software to examine the difference between the flight controller GPS and the RTK GPS. The difference is very small. 

I can see from online comments that either your directions are wrong, poorly written, or there is a glitch in how Method A works. According to those directions, we bring the GCPs into the manual tie point manager via a text file, but do nothing to ‘train’ them on images. In theory, and just like the webinar, we run the initial processing and then just tweak them in the ray cloud editor. In reality, this is not working, and it is not on us having different projections, nor are we switching the XY values. (This was the first possible source of error I examined with the research student). If we do ‘point’ a few GCPs to images in the manual tie point manager, then we can use the ray cloud editor after the initial processing. This clearly shows this is not a projection issue, and has something to do with the process. To conclude again though, this is a step I’d rather avoid, and when we use Agisoft Photoscan, this is indeed how it works. (BTW - the same thing was done in agisoft with the same coordinates, and it worked).

I had the student produce a video showing this, and the confusion with how option A is written. I can produce this and provide the link if needed.

Hi Joseph,

When using Method A described in the article about how to insert GCPs, you should be able to directly mark your GCPs in the rayCloud if you have image geotaggs. In that case, if you click 1 GCP in the left sidebar of the rayCloud, all images where it should appear are displayed in the right sidebar.

If it is not the case, then could you please explicit what you see in the rayCloud and in the right sidebar?
Also which drone did you fly? Were the geotaggs (image coordinates) measured by the drone’s GPS?
There could be something wrong with the geotaggs, perhaps regarding the altitude of the images.

If it is more convenient for you, it is possible of course to send us the link of the video to illustrate the issue.

Best regards,

I use several Quads & Planes, and since they all use WGS84 Lat/Long (w/ altitude for Z coordinate) for image location in the EXIF headers, the process works for each “Drone” & Pix4D.

As most of you, my model is in a State Plane Coordinate System. 

 

My Typical Workflow following the Pix4D instructions & Support Staff comments:

(Images are WGS84, GCP’s are State Plane, Output System is set to State Plane)

Import GCP text file.  Pay attention to the N,E vs Lat/Long fields. This is easy to OVERLOOK. Most of us export our GPS points file as Point #, N, E, Z, Description.  I just Modify the GCP text file so it matches the requirements for Pix4D input.  

Mark at least 3 images per GCP in the Basic Editor before using the RayCloud Editor to mark all images for each GCP. [In simple terms, this “raises” the 3D model to the GCP elevations, since the photos are tagged with altitude as the Z coordinate]. 

[For those of you that didn’t see the post,  Pix4D has a simple app that allows us to use automatic target recognition so we can skip ALL of this.  https://community.pix4d.com/t/4549-Try-out-our-new-tool-Pix4Dtagger- ]

 

Joseph:

I agree with your statements,  w/ the same system for images and GCP’s, it seems you should be able to skip the manual marking of GCP’s in the Basic Editor.   

Since your images and GCP’s are in the same coordinate system, are you using WGS84 for your GPS points?  If not, how are you tagging images in a State Plane (Grid System) and using ellipsoidal heights instead of altitude in the EXIF headers?  The reason I ask is I’m working on a way to do this with RTK on-board w/ Pixhawk & I’d be interested if you have image tags w/ true elevations working already.   

 

I am having the same issues (in my 3rd project ever, but not in the past 2) of GCPs being correctly imported, sitting over the image after Process 1, but when clicking on each GCP/blue circle, different images TO WHERE THAT GCP IS are appearing in the right column for me TO mark. Some images are 100mts away (and cannot be zoomed enough to find gcp) while many (6 of 10 gcps) display the same image set (wrong image set) as they do for another 5 of my gcps. After Process 1, when I click on the image generated JUST NEXT to my HOVERING GCP (blue circle) the image associated with that point of the mission CLEARLY shows the GCP marker I am trying to link to my project, but I cant. If anyone can advise why this is happening, and how to resolve it, I would be most grateful!!! Thanks