Support Website Contact Support Blog

How to downgrade a project version to upload to Pix4D Cloud (running 4.0.25)

Uploading to Pix4D Cloud can only be done from Pix4D Desktop version 4.0.25 because our servers are still running 4.0.25 (and not 4.1.22). Our developers are working on fixing a small Linux bug on the latest version.

If the project version is higher, follow the procedure below.

  1. Open the project to be converted.
  2. Make a duplicate so that you keep the project in both version. In the menu, click Project > Save project as… Name it to something like project_name_4025.p4d.
  3. Download and install the free app Notepad++, click here.
  4. Open the .p4d of the project_name_4025 with Notepad++.
  5. Edit the projectVersion and p4dVersion as below.


 
6. On the menu bar, click File > Save.
7. Download and install version 4.0.25 (see the bottom of the page), clickhere.
8. Open project_name_4025.p4d with version 4.0.25.
9. Upload to Pix4D Cloud, click here.

:bulb: If you need to work with Pix4D Cloud, we recommend to keep version 4.0.25 installed for now.

Hope it helps! Apologies for the temporary inconvenience.

2 Likes

I already have 4.1.24 installed and several current projects running. I want to use the cloud to process. How do I go about using the cloud and keeping my existing projects.  

In particular, I have one project (4.1.24) that I want to re-process on the cloud, for time’s sake.  I tried installing 4.0.25. It would not let me due to current version installed. I do not want to risk losing my current projects downgrading.

 

Please help.

Ronnie

Hi Ronald,

No worries. This is an old post and currently Pix4D Cloud runs the latest version 4.1.25. You can open the project with Pix4Dmapper 4.1.24 on desktop, and upload to our cloud servers. It will work :).

hey Julie,

I am having an issue with uploading projects created on my desktop to the cloud. For the most part everything works fine except the 3D Mesh and Point cloud. It indicates that it was successfully uploaded, however when i attempt to open it it fails/crash/just doesn’t work. I have tried multiple desktops and multiple projects but get the same result. Any thoughts on what it could be?

Hi James,

Do you upload the results only or the whole project from Pix4D Desktop?
Could you please share the link of the project, its name or ID?