Support Website Contact Support Blog

Hard Crash when processing in High Resolution

Hi,

It happened several times now to find Pix4DMapper crashed whiles processing, without any warning(it happened most likely when it was generating the 3D Mesh). I’ve managed to pull out some reports from the Windows Event Viewer and one of them has the following message:

“Windows successfully diagnosed a low virtual memory condition. The following programs consumed the most virtual memory: pix4dmapper.exe (3740) consumed 122406658048 bytes, MsMpEng.exe (4496) consumed 1983782912 bytes, and Adobe Desktop Service.exe (6628) consumed 208801792 bytes.”

At this point, Pix4D crashes regardless.

Please see attached 1 logs from Windows Event Viewer with a more detailed version of the error.

This are the specs of the PC I have used for processing:

Processor - Intel® Xeon® W-2145 CPU @ 3.70GHz, 3696 Mhz, 8 Core(s), 16 Logical Processor(s)
Installed Physical Memory (RAM) - 64.0 GB
Adapter Description - NVIDIA Quadro P4000 - 8 gddr5
Storage - 2x Samsung SSD 850 PRO 2TBPix4D Crash Log.txt (2.7 KB) Pix4D_Crash.txt (450 Bytes) Pix4D Crash Log.txt (2.7 KB)

Any suggestion will be muchly appreciated.

Thank you!

Hi,

Thank you for all the details. However, could you also send us the .log file of the processing?

Thank you in advance!

Hi,

Please see attache the processing .log report.

Many thanksRugby_Club_House.log|attachment (3.5 MB)

Could you try to send it again? I think something didn’t work.

Rugby_Club_House.log (3.5 MB)

Reattached.

Thanks!

Thank you for the .log file.

The first fix I would recommend is to slightly lower the hardware resources, as shown in the image below. The idea is to reduce the number of cores to ensure that Pix4D is not consuming more than your system is capable of sustaining.

The second advice is to close all running programs/processes on your computer. Unselect the Multiscale option in the Point Cloud generation. Reprocess Step 2. If it doesn’t work, reprocess it again with the Medium resolution for the 3D Textured Mesh.

In the meantime, update the NVIDIA drivers with Pix4Dmapper closed. Download the latest version from this link.

Afterwards, respond with an update attaching the Quality Report and the .log file.

Thanks!

Many thanks for your suggestion.

I will try to reprocess the data using the settings you recommended and i will let you know once i have some answers.

Cheers!

1 Like

Rugby_Club_House_report.pdf (318.3 KB) Hi Beata,

I have managed to re-process the data successfully this time. I’ve lowered the resources usage and processed the 3D Mesh in Medium.

I will retry using the same resources but this time i will up the 3D Mesh in High.

As per your request, i have attached only the Quality Report.PDF as the .log file exceeds the maximum upload capacity.

Many thanks!

1 Like

Happy to hear that it worked! :blush:

Let us know about the processing in high resolution whether you were able to successfully obtain it this time.

Best!

Hi again Beata, :slightly_smiling_face:

I am writing you again to let you know the results from the last processing test. As i was mentioning before, I’ve used almost the same settings for this batch, the only difference was processing the 3D Mesh in High resolution. It crashed just like the previews times.
The only thing i can think on is to try to process again stage 2 having the Multiscale box unticked.

No matter the results, i will let you know!

Many thanks!

P.S: I cannot upload the .log file because it’s exceeding the upload limit :frowning: :frowning_face:

Yes, I am very curious whether unselecting the Multiscale option would have a positive effect on the 3D Textured Mesh processing in high resolution. Whatever the results are, please share the .log file. You can take advantage of our OneDrive if the file is too big. :wink:

Best!

2 Likes