Generate Orthomosaic Failed


I am new to using Pix4DMatic and have run into a problem processing a a flight captured with a Parrot ANAFI AI. Every step worked without any issues until I tried processing the orthomosaic. It gets about 4% in then stops and says “generate orthomosaic failed.” I changed my graphics settings to the highest settings per the suggestion of another thread but this has not resolved the issue. I have also tried both the standard and hardware accelerated algorithms with no luck.

Please let me know what I can do to make this work. Thank you.

Hi @csahs

Could you please share the log file of your project? This may give us more insights into what kind of error you encountered. Also, could you tell us more about the amount of images, the type of area you want to make an orthomosaic of and the computer you have (RAM, GPU, SSD, …)?


Hi @Pierangelo_Rothenbuhler

Thanks for the quick response. I’ve attached the log file for you. I had to remove the classic event log file to make the file size small enough to upload here.

Duncan (1.8 MB)

This is a small site with a house, open area, and some wooded area. There are only 48 photos in the survey. I had no trouble creating the dense point cloud, 3d mesh, or DSM.

I’m using an HP ZBook Power G9 Mobile Workstation with a 12th Gen Intel(R) Core™ i9-12900H 2.50 GHz that has 64GB of RAM and a NVIDIA RTX A2000 8GB Laptop GPU.

Let me know if you need any further information.



The orthomosaic processed. I ran the repair function on the install wizard and restarted the program. Nothing else changed and I don’t see why that would’ve impacted the processing of the orthomosaic. I’m still interested in an explanation of the log if you are able to look at that.


Glad to hear it worked out when you reinstalled the software.

When looking at the log file I see this:

[2024-02-13 08:38:46][19%CPU][23%RAM]Generate orthomosaic tiles Invalid input
Failed to read image from file(s) C:/Users/constructionservices/Documents/pix4d/Dincan Hollow/Duncan hollow parrot check - Execution 1/0000024_gpslapse_0006.JPG

Could it be that the file was not accessible at this address? or were the images moved at some point?