Support Website Contact Support Blog

free flight mission wont start...

hi, quite new on this field… I’m flying a P4A, made a couple of grid and circular missions that went very well. I’m trying to check the free flight mission and it wont get started. I tried all 3 flight modes on the controler (A, S, P) to see if I will gain manual control, but it didn’t work…

please describe step by step the path to follow…

thanks in advance

In this type of mission, i think you must take off and pilot manually, and the “start” button only start to take shots at determined intervals.

1 Like

Sergio, thanks for the input. I did try flying manually, but when on free flight mission the controller does not respond on neither of the modes (A, S, P), so if you could, please instruct me on how to gain manual control over the drone while the free flight mission is opened…

Sorry, i’ve realised now you are flying a P4 advanced; i fly a P4 pro.

Anyway, i start the app, set the desired photos in horizontal and vertical desired distance in meters;

i tap start and manually takeoff;

when the drone is in the desired position and altitude i tap something like “start to take pictures” and fly manually the drone constantly checking the camera display, while the app take pictures at the specified interval; all of this with the drone in “P” position.

Sorry for my terrible english, hope this can be useful.

1 Like

so you use dji go4 to take off and fly? I cannot have both pix4dcapture and djigo opened and connected to the drone simultaneously…

and your English is great…

No, no.

All the steps described above are from pix4d capture, not djigo.

I take off and fly manually from the pix4d app, using my controller; in free flight mode, pix4d is only for take automated pictures in predefined distance intervals, in the meantime the drone is controlled (takeoff, flight and landing) only with the controller.

I start with DJI go only because i think is safer to format the sd card prior every missiom, then i must force the closure of the djigo app (android tablet), only after i can start pix4d capture.

ok, that is also what I try to do, but in my case, when I press start and try flying my drone manually… nothing happens…

maybe it’s a problem related to the P4 advanced.

How do you arm your drone?

Hi Gabriel,

As highlighted by Sergio, you should press Start and then take off the drone to fly it manually. If the controller is not responsive, it is quite strange as the remote controller should always overrule Pix4Dcapture actions if the pilots uses it to control the drone.

I would first suggest to check the recommendations of this article for an optimal experience:
https://support.pix4d.com/hc/en-us/articles/115004119343

Julie,

on grid and circular missions the controller does overrule Pix4dcapture. On Free mission it doesn’t…

 

Hi Gabriel,

Did you follow the free flight instructions of this article: https://support.pix4d.com/hc/en-us/articles/203081219

Note that tapping Start does not trigger any action regarding the drone. It means the camera will then take pictures based on the distance intervals you defined.

Julie and Sergio, made it!

it was my lack of knowledge about how to turn on the engines manually… works now!

thanks for you support!