Support Website Contact Support Blog

FlirVue Pro R; Processing failed; No calibrated cameras

Greetings to everyone

I have been trying to process images with more than 70% overlap from a thermal camera, Flir Vue Pro R, 13mm, 640x512, Grayscale Tif 14bit, geotagged correctly, using Desktop PIX4D Mapper Pro along with Thermal Camera Template.
The first time i did so, it was successful.
From then on, I always get the same error using the same auto- and well- recognised settings for the specific camera at “Image Properties Editor”:
For each image now appears the message “[Error]: Exception found trying to select keypoints: Input keypoints are empty” and finally “[Error]: No calibrated cameras.” and “[Error]: Error e0046: Processing failed. No calibrated cameras.” Additionally, when trying to reprocess the first dataset that was processed correctly, I now get the same errors.
However, when trying with RGB images from Flir Vuo Pro R 8bit jpgs I get the desired results every time. Also the Flir Tools show the TIF imagery fine and accurately.

IMPORTANT NOTE:

Between the first successful processing and the failed ones, there was a change that may have affected the PIX4D process.

After processing the first dataset, I shot other ones with a camera setting change and those all failed, along with the reprocess of the first successful one.

The change was that Flir had a default value of 75 in a setting called ROI. This cuts the 25% upper part as it may be sky and misaffecting the radiometrical calculations. This ROI was at 75% for the successfully processed first dataset. The next and following ones have been shot with ROI at 100% as I shoot straigh downwards from a UAV.

From Flir Vue Pro R User guide: "The ROI slider allows the user to set a region of interest (a rectangular area of pixels on the sensor array) that the Scene algorithm will use for its calculations.  This rectangular area can be configured so that varying amounts of sky will be excluded.  When set to 100, the full field of view will affect the image.  A setting of 50 will exclude the top half of the image. "

Could this be an indicator of wrong settings inside PIX4D for the pixels and the image size for the specific camera with 13mm lens and 640x512 resolution?

I also noticed at the saved Processing Options for the successful thermal dataset at 75% ROI that it has recognised automatically the “3. DSM, Orthomosaic and Index” -> Tab “Index Calculator” -> “Resolution”: Automatic: 1xGSD(13.3117 cm/pixel),

while on the following datasets with ROI set at 100%, this is not recognised accordingly, but just has “Resolution”: Automatic: 1xGSD without specification for the cm/pixel.

However, when trying to reprocess the first 75% ROI dataset with the saved settings and recognition on the resolution, it outputs the same errors as well.

 

How could I attach an image for your inspection?
Thank you for your patience and attention.

Best regards

Hi,

This is happening because the camera it is in our database with the specifications related to default mode. As we have mentioned in the request you have sent you will have to share with us the dataset as we are not sure how the images are tagged when other modes then default are used. 

Cheers,

Ina

Thank you for the reply Ina,

I have uploaded subdatasets for your inspection.

I hope a solution is soon developed as I cannot process exhibitionary datasets for my work and ascertain expenses to be made.

Best regards

I have same issues here. Images taken using FLIR VUE PRO R 19mm with frontal overlap 90% and sidelap 80%. Flight mission was planned in Tower. Images were geo-tagged using geosetter. Changed pixel size to 17um as recommended in camera settings. Used thermal template. Same error messages appear: “[Error]: Exception found trying to select keypoints: Input keypoints are empty” and finally “[Error]: No calibrated cameras.” and "[Error]: Error e0046: Processing failed. No calibrated cameras. Looking forward to hear solutions on this post.

 

 

@Sammer

To further investigate this I would need to take a look at the quality report, log file and p4d file of your project. Could you please submit a ticket with this files via our request form?

Thanks,

Ina

I’m experiencing the same problem.  It bails out before producing a quality report.  Simply won’t calibrate the cameras.

 

Update:  I was able to get it to create a mosaic after changing the calibration options to “Accurate Geolocation and orientation” and Internal Parameters = “None” and External Parameters = “All.”  It is, however, still distorted and shows the point cloud like a semisphere.  I think the solution may lie in resetting the camera model and lense corrections, but to what?  It’s a FLIR (maybe Vue Pro" with an 8 mm lense.

 

Hey Merlin,

Have you tried using the Alternative calibration method? I have tried Accurate Geolocation and Orientation couple time and I never had success with it even though the quality report looks fine.

Hi everyone,

@Merlin I would suggest opting for All prior for internal parameters, All for external one and  Alternative calibration method (as @Selim said). Have you checked if the camera parameters are correctly set: focal length and pixel size? Sometimes it happens that these parameters are wrongly written in the exif. 

The accurate geolocation and orientation it should be used only if you have accurate information (RTK for example).

Cheers,

Ina

I’m having the very same issue. Can you tell me what is happening? 

Hi Chris,

 

Could you post your Quality report here so I can take a look?

Additionally, could you check the camera model parameters associated with your camera?

How to verify that the Camera Model associated with the Camera is Correct 

 

Cheers,

Ina

Hello

 

I am having the same issue with flir vue pro r 19mm lens.

Hi Enrique,

Have you tried the solution given here? Could you post the p4d file, log file and quality report so I could take a look?

The most important at this step is for you is to check if the camera model is correctly assigned. The Vue pro 19mm we have it in our database but it might be that the distortions model is not a good fit in this case. Given this, you could try re-running step 1 with distortions set to 0. 

Could you try and let me know how it goes?

 

Cheers,

Ina