Support Website Contact Support Blog

Flight calculation time way off

Hello, I am brand new to this whole thing so i’m sure there is something that I am not understanding. I was flying my 2nd project and it seemed like the flight time calculation was way off. first I am using a Phantom 4 (not pro or advanced) with an Ipad Mini 2. The site I am flying is 2529x2575 ft and it says 13: 53s at the bottom of the screen. I started the drone in DJI Go 4 app then closed out and and flew from pix4dcapture. launched the mission. I set an alarm on my watch to go off at 13 min as this was the 2nd time I was trying to fly the site because the first time I tried to fly it I burned thru a battery and was only maybe 1/16 of the way done with the full site. I reset up the job and started it again with the above settings. after my alarm went off I connected the controller to the charging cable (controller battery started to get low) I flew for a total of 20 minutes before I had to bring the drone back home controller was at 3% battery. I only flew 3 of the planned grid flight lines of the 11 total for the project. it took 41 photos so far but this is only a 1/4 of the total job. At this rate I will have to fly it 5x on five different days because I can only get 30ish minutes out of the controller battery. I know its a large site so I understand that but why is the flight time so off it should be more like 1hr+. Am I missing something or not understanding what that means? it also seemed like the drone was flying pretty slow even though I had it set to fast. any thoughts or ideas or things I should look at would be helpful.

Thanks,
Justin

The controller battery should last most of the day. Are you sure it was fully charged? You shouldn’t need to disconnect the ipad from the controller.

What are your flight settings? Altitude, %overlap (forward & side), single or double grid? I regularly fly a site slightly smaller than yours (130 ac). Single grid 75/75 overlap at 300 ft agl takes about an hour and 4 batteries. If you fly lower or have more overlap, it will take longer.

For a 150 ac site, you will need 5-6 batteries.

Thank you for your response. I am starting to wonder if I am having issues with the controller battery. I flew the site again today using my phone (galaxy note 8) instead of the ipad and I seemed to get a better flight time but still not great. Remote controller was plugged in all night to charge. My first mission was single grid polygon 1301 ft x 1465 ft, overlap 80% (72%) Altitude 250 ft, Images 505, Path 7959ft Flight time 17min:57s. Had to bring it home to swap battery in drone. Couldn’t get the flight plan to resume so I created a new flight plan to cover the missing portion. 2nd plan: dimensions 1340ft x 889ft, Overlap 80% (72%) Altitude 250ft, Images 310, Path 4995 ft, Flight time 11min:30s. Battery on controller was at 3% when the mission ended. I plugged it into my converter in my truck to try and get more time in the middle of the 2nd mission but still discharged pretty fast during flight. I got the data I needed for the job but man its heart stopping to get to 3%!!

Yep, somethings not right with that controller battery if that is correct. I can run 4 batteries on my old P4 and still have plenty of controller battery left. If anything after 4 flights I’m concerned about my iPads battery life, but the controller is good to go.

Thanks for reply, Just did a test after having controller plugged in for a full day turned on controller and drone and just let it sit. Powered on 7:58 am - Low Battery warning at 8:21am - 23 minutes of operational time not connected to ipad or phone.

My only suggestion would be to try to make sure firmware is up to date. Maybe a FW update would clean the cobwebs out of the controller. Or the battery is just toast. I did find this thread which may shed some light:

P4 Controller Battery Issues